ACM-ICPC 2018 焦作赛区网络预赛 L Poor God Water 线性模板题 or 矩阵快速幂推导

博客目录

原题

原题传送门

  •  40.26%
  •  1000ms
  •  65536K

God Water likes to eat meat, fish and chocolate very much, but unfortunately, the doctor tells him that some sequence of eating will make them poisonous.

Every hour, God Water will eat one kind of food among meat, fish and chocolate. If there are 33 continuous hours when he eats only one kind of food, he will be unhappy. Besides, if there are 33 continuous hours when he eats all kinds of those, with chocolate at the middle hour, it will be dangerous. Moreover, if there are 33 continuous hours when he eats meat or fish at the middle hour, with chocolate at other two hours, it will also be dangerous.

Now, you are the doctor. Can you find out how many different kinds of diet that can make God Water happy and safe during NN hours? Two kinds of diet are considered the same if they share the same kind of food at the same hour. The answer may be very large, so you only need to give out the answer module 10000000071000000007.

Input

The fist line puts an integer TT that shows the number of test cases. (T \le 1000T≤1000)

Each of the next TT lines contains an integer NN that shows the number of hours. (1 \le N \le 10^{10}1≤N≤1010)

Output

For each test case, output a single line containing the answer.

样例输入复制

3
3
4
15

样例输出复制

20
46
435170

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

线性模板

只要是结论是线性的,就能套这个模板。

 

矩阵快速幂

我们以两个格子为一组,设巧克力为0,其他两个为1,2

给两个格子所有9种状态标号为0~8,设fj[i]表示格子i和格子i-1取花色j时,前i个格子的方法数。则fj[i]和fk[i-1]有题目限制条件(任意不能三连,巧克力两边必须是相同的,巧克力不能间隔相邻),见下表

标号  f[i]格子i格子i-1f[i-1]允许的花色,也就是i-1相同,i-2满足的条件
0

 

001,2
1014,5
2027,8
3100,1
4113,5
5126,7,8
6200,2
7213,4,5
8226,7

设k为fj[i]允许的花色,则有fj[i]=sum(fk[i-1]); 即线性组合。

然后我们将线性组合转化为矩阵乘法:

方阵每一行为花色j对应的允许的花色。

之后就可以矩阵快速幂了。

注意n开long long

AC代码(模板)

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <map>
#include <set>
#include <cassert>
#include<bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
#define SZ(x) ((int)(x).size())
typedef vector<int> VI;
typedef long long ll;
typedef pair<int,int> PII;
const ll mod=1000000007;
ll powmod(ll a,ll b) {ll res=1;a%=mod; assert(b>=0); for(;b;b>>=1){if(b&1)res=res*a%mod;a=a*a%mod;}return res;}
// head

int _,n;
namespace linear_seq {
    const int N=10010;
    ll res[N],base[N],_c[N],_md[N];

    vector<int> Md;
    void mul(ll *a,ll *b,int k) {
        rep(i,0,k+k) _c[i]=0;
        rep(i,0,k) if (a[i]) rep(j,0,k) _c[i+j]=(_c[i+j]+a[i]*b[j])%mod;
        for (int i=k+k-1;i>=k;i--) if (_c[i])
            rep(j,0,SZ(Md)) _c[i-k+Md[j]]=(_c[i-k+Md[j]]-_c[i]*_md[Md[j]])%mod;
        rep(i,0,k) a[i]=_c[i];
    }
    int solve(ll n,VI a,VI b) { // a 系数 b 初值 b[n+1]=a[0]*b[n]+...
//        printf("%d\n",SZ(b));
        ll ans=0,pnt=0;
        int k=SZ(a);
        assert(SZ(a)==SZ(b));
        rep(i,0,k) _md[k-1-i]=-a[i];_md[k]=1;
        Md.clear();
        rep(i,0,k) if (_md[i]!=0) Md.push_back(i);
        rep(i,0,k) res[i]=base[i]=0;
        res[0]=1;
        while ((1ll<<pnt)<=n) pnt++;
        for (int p=pnt;p>=0;p--) {
            mul(res,res,k);
            if ((n>>p)&1) {
                for (int i=k-1;i>=0;i--) res[i+1]=res[i];res[0]=0;
                rep(j,0,SZ(Md)) res[Md[j]]=(res[Md[j]]-res[k]*_md[Md[j]])%mod;
            }
        }
        rep(i,0,k) ans=(ans+res[i]*b[i])%mod;
        if (ans<0) ans+=mod;
        return ans;
    }
    VI BM(VI s) {
        VI C(1,1),B(1,1);
        int L=0,m=1,b=1;
        rep(n,0,SZ(s)) {
            ll d=0;
            rep(i,0,L+1) d=(d+(ll)C[i]*s[n-i])%mod;
            if (d==0) ++m;
            else if (2*L<=n) {
                VI T=C;
                ll c=mod-d*powmod(b,mod-2)%mod;
                while (SZ(C)<SZ(B)+m) C.pb(0);
                rep(i,0,SZ(B)) C[i+m]=(C[i+m]+c*B[i])%mod;
                L=n+1-L; B=T; b=d; m=1;
            } else {
                ll c=mod-d*powmod(b,mod-2)%mod;
                while (SZ(C)<SZ(B)+m) C.pb(0);
                rep(i,0,SZ(B)) C[i+m]=(C[i+m]+c*B[i])%mod;
                ++m;
            }
        }
        return C;
    }
    int gao(VI a,ll n) {
        VI c=BM(a);
        c.erase(c.begin());
        rep(i,0,SZ(c)) c[i]=(mod-c[i])%mod;
        return solve(n,c,VI(a.begin(),a.begin()+SZ(c)));
    }
};

int main() {
    vector<int>v;//3,9,20,46,106,244,560,1286,2956,6794,15610
        v.push_back(3);
        v.push_back(9);
        v.push_back(20);
        v.push_back(46);
        v.push_back(106);
        v.push_back(244);
        v.push_back(560);
        v.push_back(1286);
        v.push_back(2956);
        v.push_back(6794);

    while (~scanf("%d",&n)) {
        printf("%d\n",linear_seq::gao(v,n-1));
    }
}

矩阵快速幂AC代码

#include<bits/stdc++.h>
using namespace std;
#define regi register int
int const mod=1e9+7;
#define rank 9
typedef long long ll;
class mat
{
public:
    ll m[rank+1][rank+1];
    inline ll* operator[](int x){
        return this->m[x];
    }
    void clear(){
        memset(m,0,sizeof(m));
    }
};
mat inline operator*(mat a,mat b)
{
    mat ret;
    memset(&ret,0,sizeof(mat));
    for(regi i=0; i<rank; i++){
        for(regi k=0; k<rank; k++){
            for(regi j=0; j<rank; j++){
                ret[i][j]+=a[i][k]*b[k][j]%mod;
                ret[i][j]%=mod;
            }
        }
    }
    return ret;
}
mat inline mpow(mat a,ll n)
{
    mat w,ret;
    memset(&ret,0,sizeof(mat));
    w=a;
    for(regi i=0; i<rank; i++)
        ret[i][i]=1;
    for(;n;){
        if(n&1){
            ret=ret*w;
        }
        w=w*w;
        n>>=1;
    }
    return ret;
}
int main(){
    ll n,T;
    mat m,t;
    cin>>T;
    m.clear();
    m[0][1]=1;
    m[0][2]=1;
    m[1][4]=1;
    m[1][5]=1;
    m[2][7]=1;
    m[2][8]=1;
    m[3][1]=1;
    m[3][0]=1;
    m[4][3]=1;
    m[4][5]=1;
    m[5][6]=1;
    m[5][7]=1;
    m[5][8]=1;
    m[6][2]=1;
    m[6][0]=1;
    m[7][3]=1;
    m[7][4]=1;
    m[7][5]=1;
    m[8][6]=1;
    m[8][7]=1;
    while(T--){
        cin>>n;
        if(n==1){
            cout<<3<<endl;
            continue;
        }
        else if(n==2){
            cout<<9<<endl;
            continue;
        }
        t=mpow(m,n-2);
        int sum=0;
        for(int i=0;i<9;i++){
            for(int j=0;j<9;j++){
                sum+=t[i][j];
                sum%=mod;
            }
        }
        
        cout<<sum<<endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值