2299 Poj Ultra-QuickSort(归并排序求逆序数)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 46926 Accepted: 17131

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
 
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int a[500010],b[500010];
long long ans;
void mer(int s,int mid,int e)
{
    int i=s,j=mid+1,k=0;
    while(i<=mid&&j<=e)
    {
        if(a[i]>a[j])  //一定是看小的a[i]是否>a[j],成立的话从i到mid 的a[i]也是一定大于a[j].
        {
            ans+=mid-i+1;
            b[k++]=a[j++];
        }
        else
            b[k++]=a[i++];
    }
    while(i<=mid)
        b[k++]=a[i++];
    while(j<=e)
        b[k++]=a[j++];
    for(i=s,k=0;i<=e;i++,k++)
        a[i]=b[k];
}
void fen(int s,int e)
{
    if(s<e)
    {
        int mid=(s+e)/2;
        fen(s,mid);//分两部分不断递归
        fen(mid+1,e);
        mer(s,mid,e);
    }
}
int main()
{
    int n,m,i,j;
    ios::sync_with_stdio(false);
    while(cin>>n&&n)
    {
        ans=0;
        for(i=0;i<n;i++)
        {
            cin>>a[i];
        }
        fen(0,n-1);
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值