Poj 1125 Stockbroker Grapevine(floyd小变形)

Stockbroker Grapevine
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 17227  Accepted: 9306

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
 
题目大意是股票经纪人传消息,要求出那个经纪人传出了耗时最短的消息,及最短的时间。
 
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int dis[200][200],n,m;
void floyd()
{
    int i,j,k,bj;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(dis[i][j]>dis[i][k]+dis[k][j])
                {
                    dis[i][j]=dis[i][k]+dis[k][j];
                }
            }
        }
    }
    int ma=0x3f3f3f3f,tmp;//主要是求出那个经济人传的消息最短时间让所有都知道,及其最短时间。
    for(i=1;i<=n;i++ )
    {
        tmp=0,bj=0;
        for(j=1;j<=n;j++)
        {
            if(dis[i][j]>tmp)//先求出每位经纪人让所有人知道的最大时间,之所以不累加比较而直接比较最大的数,因为经纪人可以同时想多个人发送。
            {
                tmp=dis[i][j];
            }
        }
        if(ma>tmp)//与其他经纪人所用的时间比较。
        {
            k=i;
            ma=tmp;
        }
    }
    if(ma==0x3f3f3f3f)
        cout<<"disjoint"<<endl;//我仍有不解之处就是看ma是否为极大,如果ma经过一个经纪人发送后仍为0x3f3f3f3f,而经过下一个经纪人后ma比0x3f3f3f3f小。应该输
    else
        cout<<k<<" "<<ma<<endl;//出disjoint但被覆盖了,并不输出disjoint。数据太水了。。。。  如果不这么做请飘过的大神指点一下啊。。。。

}
int main()
{
    int i,j,k,num;
    while(cin>>n&&n)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(i==j)
                    dis[i][j]=0;
                else
                    dis[i][j]=0x3f3f3f3f;
            }
        }
        for(i=1;i<=n;i++)
        {
            cin>>m;
            for(j=1;j<=m;j++)
            {
                cin>>num>>k;
                dis[i][num]=k;
            }
        }
        floyd();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值