poj1125Stockbroker Grapevine

Stockbroker Grapevine

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
 

Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

 

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
 

Sample Input
  
  
3 2 2 4 3 5 2 1 2 3 6 2 1 2 2 2 5 3 4 4 2 8 5 3 1 5 8 4 1 6 4 10 2 7 5 2 0 2 2 5 1 5 0
 

Sample Output
  
  
3 2 3 10
 

Source
PKU
 刚才 有人问我输入是啥,我才发现输入也好难理解,解释一下输入:
第一组的第一行2 2 4 3 5
就是说 从1 点开始可以到达2个点  第一个 点是2 消耗的时间是4  第二个点是3 消耗的时间是5
第几行 就是从第几个点开始!

好难理解的 题意,本来 英语就不好,看完百度翻译,发现 其实我汉语也不好:
纠结的题意,就是说先判断每一个点到其他点的距离的和,这一些和构成了一个数组,这个数组里边最小的值,对应了一个点,线输出这个点,再输出这个点到其他所有点中最长的那条路,好难理解,不过不是难题,poj后台测试数据有点弱,没输出 disjoint也A了,附ac代码:
#include<stdio.h>
#include<string.h>
#define N 0x3f3f3f
int map[110][110],a[110],i,n,m,j,k,l,t,p;
int main()
{
	while(scanf("%d",&t),t)
	{
		for(i=1;i<=t;i++)
		for(j=1;j<=t;j++)
		{
			if(i!=j)
			map[i][j]=N;
			else
			map[i][j]=0;
		}
		for(i=1;i<=t;i++)
		{
			scanf("%d",&p);
			for(j=0;j<p;j++)
			{
			scanf("%d%d",&m,&n);
			if(map[i][m]>n)
			map[i][m]=n;
			}
		}
		for(i=1;i<=t;i++)//测试数据太多,建议用floyd: 
		for(j=1;j<=t;j++)
		for(k=1;k<=t;k++)
		if(map[j][k]>map[j][i]+map[i][k])
		map[j][k]=map[j][i]+map[i][k];
		memset(a,0,sizeof(a));
		int cnm=N;
		for(i=1;i<=t;i++)
		{
			for(j=1;j<=t;j++)
			a[i]+=map[i][j];
			if(cnm>a[i])
			cnm=a[i];
		}
		for(i=1;i<=t;i++)
		if(a[i]==cnm)
		{
		printf("%d",i);
		l=i;
		break;
		}
		int cnb=0;
		for(j=1;j<=t;j++)
		{
			if(cnb<map[l][j])
			cnb=map[l][j];
		}
		if(cnb!=N)
		printf(" %d\n",cnb);
		else
		printf("disjoint\n");//这一点原来没输出,不过也过了,测试数据好弱。 
	}
	return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值