Poj 2002 Squares(二分&&STL)

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17554 Accepted: 6678

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6

1

大意为,给定一些点,问能组成多少正方形(square)

此题用到了,已知两点如何去找正方形的另外两点。

有如下推导:

(图片来源:http://m.blog.csdn.net/blog/u013480600/39500427)

已知两点,可求他们之间的向量,利用所求的向量充当边,来进行旋转移动此边。看所移动到的边所战有的点是否在原来的点集中。

主要是找到,要找的两个点。则利用上边的推导可得出。(PS:已知向量为 u:(x2-x1,y2-y1)延逆时针转动后为v:(y1-y2,x2-x1),可以利用向量的乘积=0求得 ,

然后,再计算下一个可能有的点dian3=dian2+v)。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;

int n,m;
struct node
{
    int a,b;
} q[1100];

int op(node x,node y )//
{
    if(x.a==y.a)
        return x.b<y.b;
    else
        return x.a<y.a;
}

int main()
{
    int i,j,k;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=0; i<n; i++)
            scanf("%d%d",&q[i].a,&q[i].b);
        sort(q,q+n,op);//先将输入的点进行排序
        int ans=0;
        for(i=0; i<n-1; i++)
        {
            for(j=i+1; j<n; j++)
            {
                node f1,f2;
                f1.a=q[j].a+q[i].b-q[j].b;
                f1.b=q[j].b+q[j].a-q[i].a;
                if(!binary_search(q,q+n,f1,op))
                    continue;
                f2.a=q[i].a+q[i].b-q[j].b;
                f2.b=q[i].b+q[j].a-q[i].a;
                if(!binary_search(q,q+n,f2,op))//求出来了下边的点,不用改变向量,只需要此向量的出发点即可得到另一个点
                    continue;
                ans++;
            }
        }
        printf("%d\n",ans/2);//由于没有考虑顺序问题,所以要除2
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值