BNUOJ 弱校联萌十一大决战之强力热身B Carries(二分)

frog has n integers a1,a2,,an , and she wants to add them pairwise.
 
Unfortunately, frog is somehow afraid of carries (进位). She defines \emph{hardness} h(x,y) for adding x and y the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2 .
 
Find the total hardness adding n integers pairwise. In another word, find
1i<jnh(ai,aj)
.

Input

The input consists of multiple tests. For each test:
 
The first line contains 1 integer n ( 2n105 ). The second line contains n integers a1,a2,,an . ( 0ai109 ).

Output

For each test, write 1 integer which denotes the total hardness.

Sample Input

2
5 5
10
0 1 2 3 4 5 6 7 8 9

Sample Output

1
20



思路:一对一对的枚举铁定会超时.所以首先要解决这个问题.二分的时间复杂度为logn可以.

那么,还要解决进位的问题.b[j]=a[i]%tmp^k;


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<map>
#include<algorithm>
#include<queue>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
ll a[100000],b[100000];
int main()
{
    long long  n,m,i,j,k;
    while(~scanf("%lld",&n))
    {
        for(i=0; i<n; i++)
            scanf("%lld",&a[i]);
        ll tmp=1;
        ll ans=0;
        for(i=0; i<9; i++) //最多为10^9
        {
            tmp*=10;
            for(j=0; j<n; j++)
                b[j]=a[j]%tmp;
            sort(b,b+n);//为二分先排序,并且不影响进位的次数
            for(j=0; j<n; j++)
            {
                ll l=j+1,r=n;
                while(l<r)
                {
                    int mid=(l+r)>>1;
                    if(b[mid]+b[j]>=tmp)
                        r=mid;
                    else
                        l=mid+1;
                }
                ans+=n-r;
            }
        }
        printf("%lld\n",ans);
        return 0;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值