HDOJ 1010 Tempter of the Bone(DFS奇偶剪枝)


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES


题目大意:求狗能不能在T时间内刚好出来,且“.”经过后会变成“X”。

思路:因为有时间T限制所以用DFS,并且若不用奇偶剪纸会TLE。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;

int n,m,e1,e2;
int cx[]= {0,0,1,-1},cy[]= {-1,1,0,0};
bool bj;
char Ma[10][10];
int t;
void DFS(int s1,int s2,int ans)
{
    if(ans==t&&s1==e1&&s2==e2)//注意不要写成Ma[s1][s2]=='D',可能回溯的时候没有把'D',复原
        bj=true;
    if(bj)
        return;
    if( (abs(e1-s1)+abs(e2-s2))%2!=(t-ans)%2 )//奇偶剪枝就是距离为奇数,那么到达的时间也为奇数
        return ;
    for(int i=0;i<4;i++)
    {
        int x=s1+cx[i];
        int y=s2+cy[i];
        if(x>=0&&x<n&&y>=0&&y<m&&Ma[x][y]!='X')
        {
            Ma[x][y]='X';
            DFS(x,y,ans+1);
            Ma[x][y]='.';
        }
    }
}
int main()
{
    int  k,i,j,l;
    while(~scanf("%d%d%d",&n,&m,&t))
    {
        bj=false;
        int s=0;
        if(n==0&&m==0&&t==0)
            break;
        for(i=0; i<n; i++)
            scanf("%s",Ma[i]);
        int s1,s2;
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(Ma[i][j]=='S')
                {
                    s1=i;
                    s2=j;
                }
                if(Ma[i][j]=='D')
                {
                    e1=i;
                    e2=j;
                }
            }

        }
        Ma[s1][s2]='X';///一定注意把经过的路线变成‘X’,就是因为这WA了好多次
            DFS(s1,s2,0);
        if(bj)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值