POJ 1129 Channel Allocation(暴力搜--涂色问题)

                                                                                                        Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13295 Accepted: 6806

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 
 
 
题目大意:大意就是给你一些点和一些连线,构成了具有N个结点的无向图,然后要对这个无向图进行染色,使相邻两个结点颜色不同,问最少需要多少种不同的颜色。
思路:就是涂色问题,求相邻的颜色不相同所用的最少的颜色的种类。
 
#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<cmath>
#include<queue>
#define LL long long

using namespace std;
struct node
{
    int d,next[30];//分别表示相邻颜色的种数与和当前颜色相邻的颜色
} q[30];
char Map[30];
int main()
{
    int cla,i,j,l,tmp,n;
    while(~scanf("%d",&n)&&n)
    {
        for(i=1; i<=30; i++)
            q[i].d=0;
        getchar();
        for(i=1;i<=n;i++)
        {
            gets(Map);
            l=strlen(Map);
            for(j=0;j<l;j++)
            {
                if(j==1||j==0)continue;
                q[Map[0]-'A'+1 ].next[ ++q[Map[0]-'A'+1].d ]=Map[j]-'A'+1;
            }
        }
        int ma=1,col[30];bool vis[30];
        memset(col,0,sizeof(col));
        for(i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));//当新的颜色被枚举时清空标记数组
            for(j=1;j<=q[i].d;j++)
            {
                int m=q[i].next[j];//与q[i]相邻的颜色分别被枚举出来,一定是将q[i].next[j]的值拿出来,而不是直接vis[col[j]]=true。此题默认按字典所以也对
                vis[col[m] ]=true;//并标记下这种颜色
            }
            for(j=1;j<=n;j++)
            {
                if(!vis[j])//再从小编号开始遍历,开哪种颜色还没有被用
                {
                    col[i]=j;//便把没用的颜色付给当前的要涂色的部分,找到一种编号小的停止
                    break;
                }
            }
            if(ma<j)
            ma=j;
            if(ma==4)//由四色定理知一个图不能多余5种涂色
            break;
        }
        if(ma==1)
            printf("%d channel needed.\n", ma);
        else
            printf("%d channels needed.\n", ma);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值