Description
Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.
Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.
Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.
Input
* Line 1: Two space-separated integers: R and C
* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character.
* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character.
Output
* Line 1: The area of the smallest unit from which the grid is formed
Sample Input
2 5 ABABA ABABA
Sample Output
2
Hint
The entire milking grid can be constructed from repetitions of the pattern 'AB'.
做的时候,要把每行的字符和每列的字符看成一个字符,分别求行列的next,然后分别计算行列的最小循环节长度,也就是len-next[len],最后相乘即可。
Source Code
Problem: 2185 | User: 405045132 | |
Memory: 1176K | Time: 47MS | |
Language: G++ | Result: Accepted |
#include<stdio.h>
#include<string.h>
char str[10010][80];
int next1[10010];
int next2[80];
int r,c;
bool same1(int t1,int t2)
{
for(int j=0;j<c;j++)
{
if(str[t1][j]!=str[t2][j])
return false;
}
return true;
}
bool same2(int t1,int t2)
{
for(int j=0;j<r;j++)
{
if(str[j][t1]!=str[j][t2])
return false;
}
return true;
}
int _next()
{
//先求行的
next1[0]=-1;
int j=0,k=-1;
while(j<r)
{
if(k==-1 || same1(j,k))
next1[++j]=++k;
else
k=next1[k];
}
int len1=r-next1[r];
next2[0]=-1;
j=0,k=-1;
while(j<c)
{
if(k==-1 || same2(j,k))
next2[++j]=++k;
else
k=next2[k];
}
int len2=c-next2[c];
return len1*len2;
}
int main()
{
while(~scanf("%d%d",&r,&c))
{
for(int i=0;i<r;i++)
scanf("%s",str[i]);
printf("%d\n",_next());
}
return 0;
}