POJ 1160——Post Office

Post Office
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 15464Accepted: 8378

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source


很经典的一道dp题,正好锻炼我这种dp渣。

我们用dp[i][j] 来表示在前i个村子里建造j个邮局花费的代价。想想,是不是一定有个区间,它里面只有1个村子。

我们假设这个区间叫做[k +1,i ],那么在区间[1,k]里面就要建j-1个,而且我们要选择一个k,使整体的代价最小,
所以

  状态方程就是:dp[i][j] = min(dp[i][j] , dp[k][j-1]+dist),
接下来问题就是在村庄之间建造1个邮局花的代价,这个要怎么算?
我们用数组sum[i][j]表示在村庄i到j之间建立一个邮局花费的最小代价,那么造在中间一定是最好的,而当j-i+1为偶数时,例如  在 1——6之间,坐标为A1,A2,A3,A4,A5,A6,造在3的话,dist=A6-A3+A5-A3+A4-A3+A3-A2+A3-A1=
A6+A5+A4-A3-A2-A1;
造在4的话,dist=A6-A4+A5-A4+A4-A3+A4-A2+A4-A1=A6+A5+A4-A3-A2-A1,所以是一样的。

所以,sum[i][j]=sum[i][j-1]+pos[j]-pos[(i+j)>>1];

#include<stdio.h>
#include<string.h>

int sum[305][305];//第i个村庄到第j个村建一个邮局的距离

int dp[305][35];//在i个村子造j个邮局的代价

int dis[305];

int min(int a,int b)
{
return a<b?a:b;
}

int main()
{
int v,p;
while(~scanf("%d%d",&v,&p))
{
for(int i=1;i<=v;i++)
scanf("%d",&dis[i]);
memset(sum,0,sizeof(sum));
memset(dp,0,sizeof(dp));
for(int i=1;i<=v;i++)
for(int j=i+1;j<=v;j++)
sum[i][j]=sum[i][j-1]+dis[j]-dis[(i+j)>>1];
for(int i=1;i<=v;i++)
dp[i][1]=sum[1][i];//显然在i个村庄造1个的话,相当于sum[1][i]
for(int j=2;j<=p;j++)//注意循环的位置,建立j个邮局,至少j个村庄,所以村庄受邮局限制
{
for(int i=j+1;i<=v;i++)
{
dp[i][j]=0x3f3f3f;
for(int k=j-1;k<i;k++)
dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
}
}
printf("%d\n",dp[v][p]);
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值