ZOJ——3204 Connect them

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1
Hints:
A solution A is a line of p integers: a1, a2, ... ap.
Another solution B different from A is a line of q integers: b1, b2, ... bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r ( r <= p, r <= q) such that ai = bi for all 0 < i < r and ar < br
OR
(2) p < q and ai = bi for all 0 < i <= p

水题生成树,只要排序的时候处理下,如果权值相同,按顶点大小排,输出时也要按顶点大小排。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn=110;

struct node
{
int u,v;
int weight;
}edge[maxn*maxn];

struct point
{
int x,y;
}list[maxn*maxn];

int father[maxn];

void unit(int n)
{
for(int i=0;i<=n;i++)
father[i]=i;
}

int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}

void merge(int aa,int bb)
{
if(aa!=bb)
father[aa]=bb;
}

int cmp1(node a,node b)
{
if(a.weight != b.weight)
return a.weight < b.weight;
else if(a.u != b.u)
return a.u < b.u;
else
return a.v < b.v;
}

int cmp2(point a,point b)
{
if(a.x != b.x)
return a.x<b.x;
return a.y < b.y;
}

void kruskal(int n,int v)
{
unit(v);
sort(edge,edge+n,cmp1);
int m=0,cnt=0;
for(int i=0;i<n;i++)
{
int aa=find(edge[i].u);
int bb=find(edge[i].v);
if(aa!=bb && edge[i].weight)
{
merge(aa,bb);
m++;
list[cnt].x=edge[i].u;
list[cnt++].y=edge[i].v;
if(m==v-1)
break;
}
}
if(cnt!=v-1)
printf("-1\n");
else
{
sort(list,list+cnt,cmp2);
for(int i=0;i<cnt;i++)
{
printf("%d %d",list[i].x,list[i].y);
if(i<cnt-1)
printf(" ");
}
printf("\n");
}
}

int main()
{
int t,n,cnt;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
cnt=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
edge[cnt].u=min(i,j);
edge[cnt].v=max(i,j);
scanf("%d",&edge[cnt++].weight);
}
}
kruskal(cnt,n);
}
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值