Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0
Sample Output
Case 1: Yes
Case 2: No
Source
Ulm Local 1996
题意就是,从某个点出发最后回到某个点,是不是有利润。那么我们设dp[i][j]表示从i到j转换后的最大利润。那么此题就是floyd算法的变形了。
题意就是,从某个点出发最后回到某个点,是不是有利润。那么我们设dp[i][j]表示从i到j转换后的最大利润。那么此题就是floyd算法的变形了。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
double dp[35][35];
char str[20],str2[20];
int main()
{
int n,m,icase=1;
while(~scanf("%d",&n) && n)
{
memset(dp,0,sizeof(dp));
map<string,int>edge;
double rate;
edge.clear();
int tot=1;
for(int i=0;i<n;i++)
{
scanf("%s",str);
edge[str]=tot++;
}
for(int i=1;i<=n;i++)
dp[i][i]=1;
scanf("%d",&m);
while(m--)
{
scanf("%s%lf%s",str,&rate,str2);
int s=edge[str];
int t=edge[str2];
dp[s][t]=rate;
}
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(dp[i][j]<dp[i][k]*dp[k][j])
dp[i][j]=dp[i][k]*dp[k][j];
bool flag=false;
for(int i=1;i<=n;i++)
if(dp[i][i]>1)
{
flag=true;
break;
}
printf("Case %d: ",icase++);
if(flag)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}