POJ2945——Find the Clones

Description

Doubleville, a small town in Texas, was attacked by the aliens. They have abducted some of the residents and taken them to the a spaceship orbiting around earth. After some (quite unpleasant) human experiments, the aliens cloned the victims, and released multiple copies of them back in Doubleville. So now it might happen that there are 6 identical person named Hugh F. Bumblebee: the original person and its 5 copies. The Federal Bureau of Unauthorized Cloning (FBUC) charged you with the task of determining how many copies were made from each person. To help you in your task, FBUC have collected a DNA sample from each person. All copies of the same person have the same DNA sequence, and different people have different sequences (we know that there are no identical twins in the town, this is not an issue).

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 20000 people, and the length 1 ≤ m ≤ 20 of the DNA sequences. The next n lines contain the DNA sequences: each line contains a sequence of m characters, where each character is either `A', `C', `G' or `T'.

The input is terminated by a block with n = m = 0 .

Output

For each test case, you have to output n lines, each line containing a single integer. The first line contains the number of different people that were not copied. The second line contains the number of people that were copied only once (i.e., there are two identical copies for each such person.) The third line contains the number of people that are present in three identical copies, and so on: the i -th line contains the number of persons that are present in i identical copies. For example, if there are 11 samples, one of them is from John Smith, and all the others are from copies of Joe Foobar, then you have to print `1' in the first andthe tenth lines, and `0' in all the other lines.

Sample Input

9 6
AAAAAA
ACACAC
GTTTTG
ACACAC
GTTTTG
ACACAC
ACACAC
TCCCCC
TCCCCC
0 0

Sample Output

1
2
0
1
0
0
0
0
0

Hint

Huge input file, 'scanf' recommended to avoid TLE.

Source


其实不需要字典树一样可以搞定,既然在复习字典树,就用了字典树的方法,还是很简单的。。。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

struct node
{
	node *next[28];
	int num;
	node():num(0){memset(next,0,sizeof(next));}
};

node *root;
int _hash[20010];
void insert(char *s)
{
	node *p=root;
	node *q;
	int pos;
	int len=strlen(s);
	for(int i=0;i<len;i++)
	{
		pos=s[i]-'A';
		if(p->next[pos]==0)
		{
			q=new node;
			p->next[pos]=q;
			p=q;
		}
		else
			p=p->next[pos];
	}
	p->num++;
}

void dfs(node *p)
{
	if(p->num!=0)
	{
		_hash[p->num]++;
		return ;
	}	
	for(int i=0;i<26;i++)
	{
		if(p->next[i]!=0 && p->num==0)
			dfs(p->next[i]);
	}
}

void Delete(node *p)
{
	for(int i=0;i<26;i++)
	{
		if(p->next[i]!=0)
			Delete(p->next[i]);
	}
	delete p;
}

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		if(!n && !m)
			break;
		root=new node;
		char gene[22];
		memset(_hash,0,sizeof(_hash));
		for(int i=0;i<n;i++)
		{
			scanf("%s",gene);
			insert(gene);
		}
		dfs(root);
		for(int i=1;i<=n;i++)
			printf("%d\n",_hash[i]);
		Delete(root);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值