hdu3177——Crixalis's Equipment

Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2893    Accepted Submission(s): 1185


Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 

Sample Input
  
  
2 20 3 10 20 3 10 1 7 10 2 1 10 2 11
 

Sample Output
  
  
Yes No
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1789  1051  1053  1045  2037


贪心,按照预留体积和实际所需体积之间的差值从大到小排序,可以这么想,差值大的,它对体积要求大,那么肯定要放在前面去处理

#include<map>    
#include<set>    
#include<list>    
#include<stack>    
#include<queue>    
#include<vector>    
#include<cmath>    
#include<cstdio>    
#include<cstring>    
#include<iostream>    
#include<algorithm>    
    
using namespace std; 

struct node
{
	int A, B;
}equ[1010];

int cmp(node a, node b)
{
	return a.B -a.A > b.B - b.A; 	
}

int main()
{
	int t;
	int n;
	int v;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d%d", &v, &n);
		for(int i = 0; i < n; i++)
		{
			scanf("%d%d", &equ[i].A, &equ[i].B);
		}
		sort(equ, equ + n, cmp);
		bool flag = true;
		for(int i = 0; i < n; i++)
		{
			if(equ[i].B <= v)
			{
				v -= equ[i].A;
			}
			else
			{
				flag = false;
				break;
			}
		}
		if(flag)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值