hdu5063——Operation the Sequence

Operation the Sequence

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 429    Accepted Submission(s): 180


Problem Description
You have an array consisting of n integers: a1=1,a2=2,a3=3,,an=n . Then give you m operators, you should process all the operators in order. Each operator is one of four types:
Type1: O 1 call fun1();
Type2: O 2 call fun2();
Type3: O 3 call fun3();
Type4: Q i query current value of a[i], this operator will have at most 50.
Global Variables: a[1…n],b[1…n];
fun1() {
index=1;
  for(i=1; i<=n; i +=2)
    b[index++]=a[i];
  for(i=2; i<=n; i +=2)
    b[index++]=a[i];
  for(i=1; i<=n; ++i)
    a[i]=b[i];
}
fun2() {
  L = 1;R = n;
  while(L<R) {
    Swap(a[L], a[R]);
    ++L;--R;
  }
}
fun3() {
  for(i=1; i<=n; ++i)
    a[i]=a[i]*a[i];
}
 

Input
The first line in the input file is an integer T(1T20) , indicating the number of test cases.
The first line of each test case contains two integer n(0<n100000) , m(0<m100000) .
Then m lines follow, each line represent an operator above.
 

Output
For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).
 

Sample Input
  
  
1 3 5 O 1 O 2 Q 1 O 3 Q 1
 

Sample Output
  
  
2 4
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5065  5064  5062  5061  5060


关于这道题,我一开始是顺着给的操作推出位置的,后来发现这样做正好相反,反过来就对了

可以这么想:假设现在在位置p,
1)p是奇数,那么下一次在位置 p 前面的只有位置是奇数而且比p小的那些位置了
所以位置就是 (p+1)/2;反过来,上一次的位置p和这一次的位置p'的关系就是p = 2*p' - 1;
2) p是偶数,那么下一次p的位置就是(n+1)/ 2 + p / 2,反过来,上一次的位置p和这一次的位置p'的关系就是p = 2*p' - n - 1;显然此时p>=(n+1)/2;
其他操作就简单了
 

#include<set>
#include<list>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>


using namespace std;
const int MOD = 1000000007;

int cnt;
int n, m;

int op[100010];

void solve(int t)
{
    int y = 0;
    int p = t;
    for(int i = cnt - 1; i >= 0; i--)
    {
        if(op[i] == 1)
        {
            if(p <= ((n + 1) / 2))
            {
             //   printf("cur_p == %d\n", p);
                p = p * 2 - 1;
               // printf("next_p == %d\n", p);
            }
            else
            {
                p = (p - ((n + 1) / 2)) * 2;
             //   printf("%d\n", p);
            }
        }
        else if(op[i] == 2)
        {
            p = n - p + 1;
        }
        else if(op[i] == 3)
            y++;
    }
    __int64 ans = p;
    for(int i = 1; i <= y; i++)
    {
        ans = ans * ans % MOD; 
    }
    printf("%I64d\n", ans);
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        cnt = 0;
        char C[3];
        int x;
        for(int i = 0; i < m; i++)
        {
            scanf("%s%d", C, &x);
            if(C[0] == 'O')
            {
                op[cnt++] = x;
            }
            else
            {
                solve(x);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值