POJ1985——Cow Marathon

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 3759 Accepted: 1886
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.

Source

USACO 2004 February


树的直径入门题,任意从一个点出发,做一次bfs,那么距离最远的点一定是直径的一个端点(如果不是端点,那么从那个点出发一定可以到更远的点,那么就矛盾了),再从找到的那个端点来一次bfs,求出直径和另一个端点

#include <map>
#include <set>
#include <list>
#include <stack>
#include <vector>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 40010;
const int inf = 0x3f3f3f3f;

struct node
{
    int weight;
    int next;
    int to;
}edge[N << 2];

int n, m;
int end_p;
bool vis[N];
int dist[N];
int head[N];
int tot;
int maxs;

void addedge(int from, int to, int weight)
{
    edge[tot].weight = weight;
    edge[tot].to = to;
    edge[tot].next = head[from];
    head[from] = tot++;
}

void build()
{
    char dir[4];
    int u, v, w;
    memset( head, -1, sizeof(head) );
    tot = 0;
    for (int i = 0; i < m; ++i)
    {
        scanf("%d%d%d%s", &u, &v, &w, dir);
        addedge(u, v, w);
        addedge(v, u, w);
    }
}

void bfs(int s)
{
    queue<int>qu;
    memset( vis, 0, sizeof(vis) );
    while ( !qu.empty() )
    {
        qu.pop();
    }
    qu.push(s);
    dist[s] = 0;
    vis[s] = 1;
    maxs = 0;
    while ( !qu.empty() )
    {
        int u = qu.front();
        qu.pop();
        for (int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].to;
            if (!vis[v])
            {
                vis[v] = 1;
                dist[v] = dist[u] + edge[i].weight;
                qu.push(v);
                if (maxs < dist[v])
                {
                    maxs = dist[v];
                    end_p = v;
                }
            }
        }
    }
}

int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        build();
        bfs(1);
        bfs(end_p);
        printf("%d\n", maxs);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值