Worm
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2803 Accepted Submission(s): 1801
Problem Description
自从见识了平安夜苹果的涨价后,Lele就在他家门口水平种了一排苹果树,共有N棵。
突然Lele发现在左起第P棵树上(从1开始计数)有一条毛毛虫。为了看到毛毛虫变蝴蝶的过程,Lele在苹果树旁观察了很久。虽然没有看到蝴蝶,但Lele发现了一个规律:每过1分钟,毛毛虫会随机从一棵树爬到相邻的一棵树上。
比如刚开始毛毛虫在第2棵树上,过1分钟后,毛毛虫可能会在第1棵树上或者第3棵树上。如果刚开始时毛毛虫在第1棵树上,过1分钟以后,毛毛虫一定会在第2棵树上。
现在告诉你苹果树的数目N,以及毛毛刚开始所在的位置P,请问,在M分钟后,毛毛虫到达第T棵树,一共有多少种行走方案数。
突然Lele发现在左起第P棵树上(从1开始计数)有一条毛毛虫。为了看到毛毛虫变蝴蝶的过程,Lele在苹果树旁观察了很久。虽然没有看到蝴蝶,但Lele发现了一个规律:每过1分钟,毛毛虫会随机从一棵树爬到相邻的一棵树上。
比如刚开始毛毛虫在第2棵树上,过1分钟后,毛毛虫可能会在第1棵树上或者第3棵树上。如果刚开始时毛毛虫在第1棵树上,过1分钟以后,毛毛虫一定会在第2棵树上。
现在告诉你苹果树的数目N,以及毛毛刚开始所在的位置P,请问,在M分钟后,毛毛虫到达第T棵树,一共有多少种行走方案数。
Input
本题目包含多组测试,请处理到文件结束(EOF)。
每组测试占一行,包括四个正整数N,P,M,T(含义见题目描述,0<N,P,M,T<100)
每组测试占一行,包括四个正整数N,P,M,T(含义见题目描述,0<N,P,M,T<100)
Output
对于每组数据,在一行里输出一共的方案数。
题目数据保证答案小于10^9
题目数据保证答案小于10^9
Sample Input
3 2 4 2 3 2 3 2
Sample Output
4 0Hint第一组测试中有以下四种走法: 2->1->2->1->2 2->1->2->3->2 2->3->2->1->2 2->3->2->3->2
Author
Linle
Source
Recommend
lcy | We have carefully selected several similar problems for you:
2084
1466
2059
1058
1160
水题dp题
水题dp题
#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int dp[105][105];
int main()
{
int n, p, m, t;
while (~scanf("%d%d%d%d", &n, &p, &m, &t))
{
memset (dp, 0, sizeof(dp));
int l = p - 1, r = p + 1;
dp[p][0] = 1;
for (int i = 1; i <= m; i++)
{
for (int j = (l >= 1 ? l : 1); j <= (r <= n ? r : n); j++)
{
if (j > 1)
{
dp[j][i] += dp[j - 1][i - 1];
}
if (j < n)
{
dp[j][i] += dp[j + 1][i - 1];
}
l--;
r++;
}
}
printf("%d\n", dp[t][m]);
}
return 0;
}