hdu2836——Traversal

194 篇文章 0 订阅

Traversal

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 742    Accepted Submission(s): 275


Problem Description
I arrive at a big lake and I have to cross it. Luckily, I’m a very good jumper, but the lake is too big to be crossed in one jump. On the shore, I find N boxes of different heights, set in a certain order. If I throw a box into the lake, it will float and it will have the same height as on the shore. This is good, because I intend to throw some boxes into the lake and get from one shore to the other by jumping from box to box. The only things to consider are:
The lake is big, so I must throw at least 2 boxes, which means that in order to cross the lake I have to make at least 3 jumps.
Not all the boxes have to be thrown; some of them may be ignored.
The boxes can be thrown into the lake only in the order they are found on the shore and I have to jump on them in this order.
The height difference between two consecutive boxes I use must be at most H meters, because I can jump a lot in length, but I have some problems with jumping in height.The height of a box doesn’t change when I jump on it.
I’m always able to jump from the shore to a box and from a box to the shore, no matter what the height of the box is.

Facing so many possibilities that respect the above conditions, I begin counting the number of possibilities that I have, instead of actually crossing the lake. I quickly find the answer and I wonder whether you can also find it as fast as I did.

Task

Write a program that determines the number of possibilities to cross the lake in the above conditions. Since the number can be quite big, you only have to output the remainder of this number, when divided by 9901.
 

Input
There are multiple test cases. Each test case contains two integers N and H, separated by a space, representing the number of boxes and the maximum height difference between two consecutive boxes thrown into the lake. The following N lines contain the heights of the boxes, in the order the boxes are set on the shore. The (i+1)th line contains the height of the ith box.
 

Output
For each test case you should output a single line, containing the number of possibilities modulo 9901.

Constraints

1 < N < 100 001
0 < H < 100 000 001
The height of any box is a strictly positive integer and does not exceed 100 000 000
 

Sample Input
  
  
4 2 1 3 7 5
 

Sample Output
  
  
4
Hint
Explanation There are 4 possibilities: 1 3 1 3 5 3 5 7 5
 

Source
2009 Multi-University Training Contest 3 - Host by WHU

线段树dp

  #include <map>  
    #include <set>  
    #include <list>  
    #include <queue>  
    #include <stack>  
    #include <vector>  
    #include <cmath>  
    #include <cstdio>  
    #include <cstdlib>  
    #include <cstring>  
    #include <iostream>  
    #include <algorithm>  
      
    using namespace std;  
    const int N = 100010;  
    __int64 dp[N];  
    int xis[N];  
    int arr[N];  
    int cnt;  
      
    struct node  
    {  
        int l, r;  
        __int64 sum;  
    }tree[N << 2];  
      
    int BinSearch(int val)  
    {  
        int l = 1, r = cnt, mid, ans;  
        while (l <= r)  
        {  
            mid = (l + r) >> 1;  
            if (xis[mid] == val)  
            {  
                ans = mid;  
                break;  
            }  
            else if (xis[mid] > val)  
            {  
                r = mid - 1;  
            }  
            else  
            {  
                l = mid + 1;  
            }  
        }  
        return ans;  
    }  
      
    int BinSearch_left(int val)  
    {  
        int l = 1;  
        int r = cnt, mid, ans;  
        while (l <= r)  
        {  
            mid = (l + r) >> 1;  
            if (xis[mid] >= val)  
            {  
                ans = mid;  
                r = mid - 1;  
            }  
            else  
            {  
                l = mid + 1;  
            }  
        }  
        return ans;  
    }  
      
    int BinSearch_right(int val)  
    {  
        int l = 1;  
        int r = cnt, mid, ans;  
        while (l <= r)  
        {  
            mid = (l + r) >> 1;  
            if (xis[mid] <= val)  
            {  
                ans = mid;  
                l = mid + 1;  
            }  
            else  
            {  
                r = mid - 1;  
            }  
        }  
        return ans;  
    }  
      
    void build(int p, int l, int r)  
    {  
        tree[p].l = l;  
        tree[p].r = r;  
        tree[p].sum = 0;  
        if (l == r)  
        {  
            return;  
        }  
        int mid = (l + r) >> 1;  
        build(p << 1, l, mid);  
        build(p << 1 | 1, mid + 1, r);  
    }  
      
    void update(int p, int pos, __int64 val)  
    {  
        if (tree[p].l == tree[p].r)  
        {  
            tree[p].sum += val;  
            return;  
        }  
        int mid = (tree[p].l + tree[p].r) >> 1;  
        if (pos <= mid)  
        {  
            update(p << 1, pos, val);  
        }  
        else  
        {  
            update(p << 1 | 1, pos, val);  
        }  
        tree[p].sum = tree[p << 1].sum + tree[p << 1 | 1].sum;  
        tree[p].sum %= 9901;  
    }  
      
    __int64 query(int p, int l, int r)  
    {  
        if (tree[p].l >= l && tree[p].r <= r)  
        {  
            return tree[p].sum;  
        }  
        int mid = (tree[p].l + tree[p].r) >> 1;  
        if (r <= mid)  
        {  
            return query(p << 1, l, r);  
        }  
        else if (l > mid)  
        {  
            return query(p << 1 | 1, l, r);  
        }  
        else  
        {  
            return query(p << 1, l, mid) + query(p << 1 | 1, mid + 1, r);  
        }  
    }  
      
    int main()  
    {  
        int n, d;  
        while(~scanf("%d%d", &n, &d))  
        {  
            memset (dp, 0, sizeof(dp));  
            __int64 ans = 0;  
            for (int i = 1; i <= n; ++i)  
            {  
                scanf("%d", &arr[i]);  
                xis[i] = arr[i];  
            }  
            sort(xis + 1, xis + n + 1);  
            cnt = unique(xis + 1, xis + n + 1) - xis - 1;  
            build(1, 1, cnt);  
            dp[1] = 0;  
            update(1, BinSearch(arr[1]), dp[1] + 1);  
            int l, r;  
            for (int i = 2; i <= n; i++)  
            {  
                l = BinSearch_left(arr[i] - d);  
                r = BinSearch_right(arr[i] + d);  
                dp[i] = query(1, l, r);  
                dp[i] %= 9901;  
                int x = BinSearch(arr[i]);  
                update(1, x, dp[i] + 1);  
                ans += dp[i];  
                ans %= 9901;  
            }  
            printf("%I64d\n", ans);  
        }  
        return 0;  
    }  


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值