hdu4965---Fast Matrix Calculation(矩阵)

94 篇文章 0 订阅

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

Output
For each case, output the sum of all the elements in M’ in a line.

Sample Input

4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0

Sample Output

14 56

Author
SYSU

Source
2014 Multi-University Training Contest 9

Recommend
We have carefully selected several similar problems for you: 5189 5188 5186 5185 5184

直接按题意的做法,搞出一个1000*1000的矩阵,光一次乘法就超时了

注意到C = A*B
C * C * ….C = A(B*A) (B*A) ….. *B
其中B*A是一个k*k的矩阵,做n^2 - 1次的快速幂,这样就把时间控制下来了

/*************************************************************************
    > File Name: hdu4965.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年03月16日 星期一 17时51分56秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

int A[1010][10];
int B[10][1010];
int D[1010][1010];
int ans[1010][1010];

int K;

class MARTIX
{
    public:
        int mat[10][10];
        MARTIX()
        {
            memset (mat, 0, sizeof(mat));
        }
        MARTIX operator * (const MARTIX &b)const;
        MARTIX& operator = (const MARTIX &b);
};

MARTIX MARTIX :: operator * (const MARTIX &b)const
{
    MARTIX C;
    for (int i = 0; i < K; ++i)
    {
        for (int j = 0; j < K; ++j)
        {
            C.mat[i][j] = 0;
            for (int k = 0; k < K; ++k)
            {
                C.mat[i][j] += this -> mat[i][k] * b.mat[k][j];
                C.mat[i][j] %= 6;
            }
        }
    }
    return C;
}

MARTIX& MARTIX :: operator = (const MARTIX &b)
{
    for (int i = 0; i < K; ++i)
    {
        for (int j = 0; j < K; ++j)
        {
            this -> mat[i][j] = b.mat[i][j];
        }
    }
    return *this;
}

MARTIX fastpow(MARTIX A, int n)
{
    MARTIX ans;
    for (int i = 0; i < K; ++i)
    {
        ans.mat[i][i] = 1;
    }
    while (n)
    {
        if (n & 1)
        {
            ans = ans * A;
        }
        n >>= 1;
        A = A * A;
    }
    return ans;
}

int main()
{
    int n;
    while (~scanf("%d%d", &n, &K))
    {
        if (!n && !K)
        {
            break;
        }
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < K; ++j)
            {
                scanf("%d", &A[i][j]);
            }
        }
        for (int i = 0; i < K; ++i)
        {
            for (int j = 0; j < n; ++j)
            {
                scanf("%d", &B[i][j]);
            }
        }
        MARTIX C;
        for (int i = 0; i < K; ++i)
        {
            for (int j = 0; j < K; ++j)
            {
                for (int k = 0; k < n; ++k)
                {
                    C.mat[i][j] += B[i][k] * A[k][j];
                    C.mat[i][j] %= 6;
                }
            }
        }
        C = fastpow(C, n * n - 1);
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < K; ++j)
            {
                D[i][j] = 0;
                for (int k = 0; k < K; ++k)
                {
                    D[i][j] += A[i][k] * C.mat[k][j];
                    D[i][j] %= 6;
                }
            }
        }
        int res = 0;
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < n; ++j)
            { 
                ans[i][j] = 0;
                for (int k = 0; k < K; ++k)
                {
                    ans[i][j] += D[i][k] * B[k][j];
                    ans[i][j] %= 6;
                }
                res += ans[i][j]; 
            }
        }
        printf("%d\n", res);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值