ZOJ3203--Light Bulb(三分法)

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

Author: GUAN, Yao
Source: The 6th Zhejiang Provincial Collegiate Programming Contest
Submit Status

三分法,在某一个位置,灯,人头顶和墙角三点一线,从这个点A开始走到墙角,影子长度先增后减,是一个凸函数,可以用三分法求解

显然 A = D(Hh)H , 每次得到的影子长度为 len = (Dx)+H D(Hh)x

然后三分求解即可,注意精度

/*************************************************************************
    > File Name: ZOJ3203.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年04月05日 星期日 15时23分34秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-9;
typedef long long LL;
typedef pair <int, int> PLL;

double H, h, D;

double calc(double x)
{
    return H + D - x - D * (H - h) / x;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%lf%lf%lf", &H, &h, &D);
        double l = D * (H - h) / H, r = D;
        double mid, midmid, midmidarea, midarea;
        while (l + eps <= r)
        {
            mid = (l + r) / 2;
            midmid = (mid + r) / 2;
            midarea = calc(mid);
            midmidarea = calc(midmid);
            if (midarea >= midmidarea)
            {
                r = midmid;
            }
            else
            {
                l = mid;
            }
        }
        printf("%.3f\n", calc(l));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值