POJ3345---Bribing FIPA(树形dp+背包)

175 篇文章 0 订阅

Description

There is going to be a voting at FIPA (Fédération Internationale de Programmation Association) to determine the host of the next IPWC (International Programming World Cup). Benjamin Bennett, the delegation of Diamondland to FIPA, is trying to seek other delegation’s support for a vote in favor of hosting IWPC in Diamondland. Ben is trying to buy the votes by diamond gifts. He has figured out the voting price of each and every country. However, he knows that there is no need to diamond-bribe every country, since there are small poor countries that take vote orders from their respected superpowers. So, if you bribe a country, you have gained the vote of any other country under its domination (both directly and via other countries domination). For example, if C is under domination of B, and B is under domination of A, one may get the vote of all three countries just by bribing A. Note that no country is under domination of more than one country, and the domination relationship makes no cycle. You are to help him, against a big diamond, by writing a program to find out the minimum number of diamonds needed such that at least m countries vote in favor of Diamondland. Since Diamondland is a candidate, it stands out of the voting process.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers n (1 ≤ n ≤ 200) and m (0 ≤ m ≤ n) which are the number of countries participating in the voting process, and the number of votes Diamondland needs. The next n lines, each describing one country, are of the following form:

CountryName DiamondCount DCName1 DCName1 …

CountryName, the name of the country, is a string of at least one and at most 100 letters and DiamondCount is a positive integer which is the number of diamonds needed to get the vote of that country and all of the countries that their names come in the list DCName1 DCName1 … which means they are under direct domination of that country. Note that it is possible that some countries do not have any other country under domination. The end of the input is marked by a single line containing a single # character.

Output

For each test case, write a single line containing a number showing the minimum number of diamonds needed to gain the vote of at least m countries.

Sample Input

3 2
Aland 10
Boland 20 Aland
Coland 15
#

Sample Output

20

Source
Tehran 2006

简单的树形dp背包
dp[u][num] 表示在以u为根的子树里得到num个城市的代价
输入注意下,别弄错了

/*************************************************************************
    > File Name: POJ3345.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月11日 星期一 20时24分34秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

int num[210];
int in_deg[210];
int dp[210][210];
vector <int> tree[210];
int w[210];
map <string, int> mp;
char str[110];
char str2[110];
string tmp;

void DP(int u) {
    num[u] = 1;
    int size = tree[u].size();
    dp[u][0] = 0;
    if (!size) {
        dp[u][1] = w[u];
        return;
    }
    for (int i = 0; i < size; ++i) {
        int v = tree[u][i];
        DP(v);
        num[u] += num[v];
    }
    dp[u][num[u]] = w[u];
    for (int i = 0; i < size; ++i) {
        int v = tree[u][i];
        for (int j = num[u] - 1; j >= 0; --j) {
            for (int k = 0; k <= j && k <= num[v]; ++k) {
                dp[u][j] = min(dp[u][j], dp[v][k] + dp[u][j - k]);
            }
        }
    }
}

int main() {
    int n, m;
    while (~scanf("%s", str)) {
        if (str[0] == '#') {
            break;
        }
        mp.clear();
        n = 0;
        scanf("%d", &m);
        for (int i = 0; str[i] != '\0'; ++i) {
            n = n * 10 + str[i] - '0';
        }
        int cnt = 0;
        memset(dp, inf, sizeof(dp));
        for (int i = 0; i <= n; ++i) {
            tree[i].clear();
            in_deg[i] = 0;
        }
        getchar();
        for (int i = 1; i <= n; ++i) {
            getline(cin, tmp);
            int len = tmp.length();
            int j = 0;
            while (tmp[j] != ' ') {
                str[j] = tmp[j];
                ++j;
            }
            str[j] = '\0';
            if (mp.find(str) == mp.end()) {
                mp[str] = ++cnt;
            }
            w[mp[str]] = 0;
            ++j;
            while (j < len && tmp[j] >= '0' && tmp[j] <= '9') {
                w[mp[str]] = w[mp[str]] * 10 + tmp[j++] - '0';
            }
            if (j == len) {
                continue;
            }
            int len2 = 0;
            ++j;
            for (; j < len; ++j) {
                if (tmp[j] == ' ') {
                    str2[len2] = '\0';
                    if (mp.find(str2) == mp.end()) {
                        mp[str2] = ++cnt;
                    }
                    tree[mp[str]].push_back(mp[str2]);
                    ++in_deg[mp[str2]];
                    len2 = 0;
                }
                else {
                    str2[len2++] = tmp[j];
                }
            }
            str2[len2] = '\0';
            if (mp.find(str2) == mp.end()) {
                mp[str2] = ++cnt;
            }
            tree[mp[str]].push_back(mp[str2]);
            ++in_deg[mp[str2]];
        }
        for (int i = 1; i <= n; ++i) {
            if (!in_deg[i]) {
                tree[0].push_back(i);
                w[0] += w[i];
            }
        }
        DP(0);
        int ans = inf;
        for (int i = m; i <= n; ++i) {
            ans = min(ans, dp[0][i]);
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值