hduoj 1004 Let the Balloon Rise

hduoj 1004 Let the Balloon Rise

思路:排序+简单的计数
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

中文:
问题描述
再次比赛时间! 看到气球漂浮在周围真是令人兴奋。 但要告诉您一个秘密,法官最喜欢的时间是猜测最流行的问题。 比赛结束后,他们将对每种颜色的气球进行计数并找到结果。

今年,他们决定把这份可爱的工作留给您。

输入值
输入包含多个测试用例。 每个测试用例均以数字N(0 <N <= 1000)开头-分发的气球总数。 接下来的N行各包含一种颜色。 气球的颜色是由最多15个小写字母组成的字符串。

N = 0的测试用例将终止输入,并且该测试用例将不被处理。

输出量
对于每种情况,请在一行上打印气球颜色以解决最常见的问题。 可以保证每个测试用例都有唯一的解决方案。


#include<algorithm> 
#include<string>
#include<cstdio>
using namespace std;
struct ball{
	int sum;
	string co;
}b[1100];
bool cmp(ball c,ball d){
	return c.sum<d.sum;
}
int main(){
	int n;
	while(cin>>n&&n>0){
		for(int i=0;i<n;i++){
			cin>>b[i].co;
			b[i].sum=1;
		}
		
		for(int i=0;i<n;i++){
			for(int j=i+1;j<n;j++){
				if(b[i].co==b[j].co){
					b[i].sum++;
				}
			}
		}
		sort(b,b+n,cmp);
		cout<<b[n-1].co<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值