1015 Reversible Primes 可逆质数

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

bool isPrime(int number)
{
  if(number == 1) return false;
  for (int i = 2; i <= sqrt(number); i++)
  {
    if (number % i == 0)
      return false;
  }
  return true;
}

void to_radix(int number, vector<int> &res, int radix)
{
  while (number)
  {
    res.push_back(number % radix);
    number /= radix;
  }
  reverse(res.begin(), res.end());
  return;
}

int to_number(vector<int> &numbers, int radix)
{
  int res = 0;
  for (auto num : numbers)
  {
    res = res * radix + num;
  }
  return res;
}

int main()
{
  while (true)
  {
    int number = 0, radix = 0;
    cin >> number;
    if (number < 0)
      break;
    cin >> radix;

    if (!isPrime(number))
    {
      cout << "No" << endl;
      continue;
    }

    vector<int> radix_number;
    to_radix(number, radix_number, radix);
    reverse(radix_number.begin(), radix_number.end());
    int reverse_number = to_number(radix_number, radix);

    if (!isPrime(reverse_number))
    {
      cout << "No" << endl;
      continue;
    }

    cout << "Yes" << endl;
  }
  return 0;
}

 总结

1. 首先根据题意,写出main函数的主要部分,然后根据需要实现对应的函数。

2. 判断质数,明确1不是质数,判断质数可以采用循环到开方数位置即可。另外可以参考埃氏筛确定构造质数地图,然后判定,不过本题时间复杂度允许,无需构造。

3. 剩下的就是进制转化,老生常谈了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值