1015 Reversible Primes (20 分)(素数+进制转换)

该博客主要介绍了如何判断一个数在特定基数下是否为可逆质数,即其反转数同样为质数。通过实现一个素数判断函数和一个数的基数转换函数,利用栈来存储和转换数字,然后检查转换后的数是否仍为素数。示例代码中给出了具体的实现细节,并展示了样例输入和输出。
摘要由CSDN通过智能技术生成

1015 Reversible Primes (20 分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

分析:

两个函数一个是isprime素数判断函数,另一个是转换函数,我这里用栈来临时存储了,然后在进行逐位转10进制,最后判断是否是素数即可

代码

#include<bits/stdc++.h>
using namespace std;
bool is_prime(int n){
	if(n<=1) return false;
	int sqr=(int)sqrt(1.0*n);
	for(int i=2;i<=sqr;i++){
		if(n%i==0){
			return false;
		}
	}
	return true;
}
int change(int a,int b){
	stack<int> s;
	while(a!=0){
		int tmp=a%b;
		s.push(tmp);
		a/=b;
	}
    int sum=0;int k=0;
	while(!s.empty()){
		sum+=s.top()*pow(b,k);
	    k++;
		s.pop();
	}
	return sum;

}
int main(){
	
	int a,b;
	while(cin>>a){
		if(a<0) break;
		cin>>b;
		int tmp=change(a,b);
		if(is_prime(a)&&is_prime(tmp)){
			printf("Yes\n");
		}
		else printf("No\n");
		
	}
	
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值