1012 The Best Rank 最佳排名

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include <iostream>
#include <vector>
#include <unordered_map>
#include <cmath>
#include <algorithm>
using namespace std;

unordered_map<string, vector<int>> grades;
vector<int> course_grade[4];    // A C M E vector

int get_rank(vector<int> &arr, int target)
{
    int a = 0, b = arr.size() - 1, mid, result = -1;
    while(a <= b){
        mid = a + b >> 1;
        if(target > arr[mid]) b = mid - 1;
        if(target < arr[mid]) a = mid + 1;
        if(target == arr[mid])
        {
            result = mid;
            b = mid - 1;
        }
    }
    return result;
}

int main(){
    int n, m; // 记录数、查询次数
    cin >> n >> m;
    while(n--)
    {
        string id;
        cin >> id;
        int g[4] = {0}; // A C M E int
        for(int i = 1; i < 4; i ++) cin >> g[i];
        g[0] = round((g[1]+g[2]+g[3])/3.0);
        for(int i = 0; i < 4; i ++)
        {
            course_grade[i].push_back(g[i]);
            grades[id].push_back(g[i]);
        }
    }
    
    for(int i = 0; i < 4; i ++) 
    {
        sort(course_grade[i].begin(), course_grade[i].end());
        reverse(course_grade[i].begin(), course_grade[i].end());
    }
    
    char course_name[] = "ACME";
    while(m--)
    {
        string id;
        cin >> id;
        if(grades.count(id) == 0) puts("N/A");
        else
        {
            int rank = 2000;
            int course_index;
            for(int i = 0; i < 4; i++)
            {
                int r = get_rank(course_grade[i], grades[id][i]);
                if(rank > r){
                    rank = r;
                    course_index = i;
                }
            }
            cout << rank + 1 << ' ' << course_name[course_index] << endl;
        }
    }
    return 0;
}

 总结

1. 一道思路简单,流程复杂的题,主要解决点

        1.1 算四舍五入平均值

        1.2 各科成绩排序

        1.3 同位次排名相同

        1.4 按科目优先级排序

2. 排序思想

        2.1 将各科成绩分别列到一个数组中,集中处理

        2.2 用二分法找逆序排序后相同成绩情况下最靠左的一个下标

3. 四舍五入,这里用到cmath中的round函数,对于int的除法,只要除一个浮点型,就能类型转换成浮点除法

4. 成绩优先级,只需要将成绩列表按优先级排序,依次比较

5. 学生成绩存储采用map,以学号为键,各成绩组成数组为值

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值