1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题意解析:
给出n个考生的编号,及其C语言,数学,英语三门课程的成绩。随后进行查询,输入考生编号,输出考生的最佳排名。(即三门课程或者平均分等4类排名中最靠前的排名)以及最佳排名对应的种类。(若最靠前排名不唯一,则按照平均分》C》M》E的优先级输出。)

代码及思路如下:

#include<map>
#include<algorithm>
#include<string>
#include<math.h>
#include<iostream>
using namespace std;
#define ep 1e-7
struct student{
	double g[4];	//为了简化运算,都设置为double类型,且g[0]-g[3]分别为平均分,C,数学英语分数
	int rank[4];	//数组存放平均分,C,数学英语4种标准下的排名。
	int flag;	//保存数组下标,以便在排序后回复。
}stu[2020];
map<string,int> sti;
map<int,string> its;
int pry,num=1;
bool cmp(student a,student b){	//4种标准下的分数降分排序
	return a.g[pry]>b.g[pry];
}
bool cmp1(student a,student b){	//编号从小到大回复。
	return a.flag<b.flag;
}
int change(string str){	//将输入考生编号转换为int型
	if(sti.find(str)!=sti.end())	return sti[str];
	else{
		sti[str]=num;
		its[num]=str;
		return num++;
	}
}
int main(){
	int n,m,num;
	cin>>n>>m;
	double x,y,z;
	string s;
	for(int i=1;i<=n;i++){	//将输入考生信息依次存储到stu[1],stu[2],stu[3].....stu[n],且原下标保存,以便排序,便捷输出
		cin>>s>>x>>y>>z;
		int id=change(s);
		stu[id].flag=id;
		stu[id].g[1]=x,stu[id].g[2]=y,stu[id].g[3]=z;
		stu[id].g[0]=(x+y+z)/3.0;
	}
	for(pry=0;pry<4;pry++){
		sort(stu+1,stu+1+n,cmp);
		stu[1].rank[pry]=1;
		int index=1;
		double temp=stu[1].g[pry];	
		for(int i=2;i<=n;i++){
			if(fabs(stu[i].g[pry]-temp)<ep){	//存在并列排名的情况,比如1 1 3 4 5名。
				stu[i].rank[pry]=index;	
			}
			else{
				stu[i].rank[pry]=index=i;
				temp=stu[i].g[pry];
			}
		}
	}
	sort(stu+1,stu+1+n,cmp1);	//恢复下标
	for(int i=0;i<m;i++){
		cin>>s;
		if(sti.find(s)!=sti.end()){
			int t=sti[s],index=0,r=6666;
			for(int j=0;j<4;j++){
				if(stu[t].rank[j]<r){
					r=stu[t].rank[j];
					index=j;
				}
			}
			cout<<r<<" ";
			if(index==0)	cout<<"A"<<endl;
			else if(index==1)	cout<<"C"<<endl;
			else if(index==2)	cout<<"M"<<endl;
			else	cout<<"E"<<endl;
		}
		else	cout<<"N/A"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值