自测-4 Have Fun with Numbers (20分)

14 篇文章 0 订阅
3 篇文章 0 订阅

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

代码如下:

#include<stdio.h>
#include<string.h>
int main(){
	int i,j,len,t=0,num;
	char temp,a[25],b[25],c[25];
	scanf("%s",&a);  //不能是&a[25],输出也是一样; 
	len=strlen(a);
 for(i = len - 1; i >= 0; i--){
        num = (a[i] - '0')*2 +t;
        t = 0;
        if(num > 9){
            num = num % 10;
            t++;
        }
        b[i] = num + '0';
    }
    if(t==1){
    	c[0]='1';
    	strcat(c,b);
	}	
	else
		strcpy(c,b); 
	for(i=1;i<len;i++)
		for(j=0;j<len-i;j++){
			if(a[j]>a[j+1]){
				temp=a[j];
				a[j]=a[j+1];
				a[j+1]=temp;
			}	
		}
		
	for(i=1;i<len;i++)
		for(j=0;j<len-i;j++){
			if(b[j]>b[j+1]){
				temp=b[j];
				b[j]=b[j+1];
				b[j+1]=temp;
			}	
		}
	if(strcmp(a,b)==0&&t!=1)
		printf("Yes\n");
	else 
		printf("No\n"); 
	for(i=0;c[i]!='\0';i++)   
		printf("%d",c[i]-'0');
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值