PAT 1008 Elevator HERODING的PAT之路

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:

For each test case, print the total time on a single line.
Sample Input:

3 2 3 1

Sample Output:

41

题目大意:
电梯从0层开始向上,给出该电梯依次按顺序停的楼层数,并且已知上升需要6秒/层,下降需要4秒/层,停下来的话需要停5秒,问⾛完所有需要停的楼层后总共花了多少时间。

解题思路:
这道题目可谓非常简单了,没有任何复杂的算法,就是简单的判断就行,当然题目意思首先得读懂,代码如下:

#include<iostream>

using namespace std;

int main() {
    int cur = 0, count = 0;
    int floor;
    // 这里用巧了,目的是应付输入的N,因为没有N也可以直接输入,所以这里floor既有应付输入N,也表示输入的层数
    cin >> floor;
    while(cin >> floor) {
        // 如果向上
        if(floor > cur) count += (floor - cur) * 6;
        // 如果向下
        else count += (cur - floor) * 4;
        cur = floor;
        // 别忘了停靠了5s
        count += 5;
    }
    cout << count;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

HERODING77

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值