PAT 甲级 1035 Password (20分)

题目

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input2:

1
team110 abcdefg332

Sample Output2:

There is 1 account and no account is modified

Sample Input3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output3:

There are 2 accounts and no account is modified

Code:

#include<bits/stdc++.h> 
using namespace std;

struct Information{
	string account,pass;
	int flag;
}info[1005];

int main(){
	int n,cnt=0;
	cin>>n;
	for(int i=0;i<n;i++){
		string temp;
		cin>>info[i].account>>temp;
		int flag=0;
		for(int j=0;j<temp.length();j++){
			switch(temp[j]){
				case '1':
					temp[j]='@';
					flag++;
					break;
				case '0':
					temp[j]='%';
					flag++;
					break;
				case 'l':
					temp[j]='L';
					flag++;
					break;
				case 'O':
					temp[j]='o';
					flag++;
					break;
				default:
					break;
			}
		}
		info[i].pass=temp;
		info[i].flag=flag;
		if(info[i].flag>0) cnt++;
	}
	
	if(cnt==0){
		if(n!=1) printf("There are %d accounts and no account is modified",n);
		else printf("There is 1 account and no account is modified");
	}
	else{
		cout<<cnt<<endl;
		for(int i=0;i<n;i++){
			if(info[i].flag>0){
				cout<<info[i].account<<" "<<info[i].pass<<endl;
			}
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值