【PAT】1035. Password (20)

题目描述

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

翻译:为了准备PAT,裁判有时需要为用户随机生成密码。问题是总是有一些难以识别的密码,由于1和l(L的小写字母),或者0和O(o的大写字母)。一个解决方法是用@替换1,用%替换0,用L替换l,用o替换O。现在你的任务是写一个程序来帮助裁判核对账户信息并改变难以识别的密码。

INPUT FOMRAT

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,包含一个正整数N(<=1000),接着是N行账户信息。每条账户信息包含一个用户名和一个密码,都是不包括空格的不超过10个字符的字符串。

OUTPUT FOMRAT

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

翻译:对于每组输入数据,首先输出需要修改的密码总数M,接着输出N行修改后的账户信息,即用户名和对应的修改后的密码。账户必须按照和读入顺序一样的顺序输出。如果没有账户需要修改,输出一行 “There are N accounts and no account is modified”,N为账户总数。但是,如果N为1,你必须输出 “There is 1 account and no account is modified” 。


Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa


Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified


Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified


解题思路

模拟题目内容即可,数据保存可以考虑用vector。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
typedef pair<string,string> P;
vector<P> v;
int M; 
int main(){
    scanf("%d",&M);
    string name,s;
    for(int i=0;i<M;i++){
        cin>>name>>s;
        int flag=0;
        for(int i=0;i<s.length();i++){
            if(s[i]=='l')s[i]='L',flag=1;
            if(s[i]=='O')s[i]='o',flag=1;
            if(s[i]=='1')s[i]='@',flag=1;
            if(s[i]=='0')s[i]='%',flag=1; 
        }
        if(flag==1)v.push_back(P(name,s)); 
    }
    if(v.size()==0){
        if(M==1)cout<<"There is 1 account and no account is modified"<<endl;
        else cout<<"There are "<<M<<" accounts and no account is modified"<<endl;
    }else{
        cout<<v.size()<<endl;
        for(int i=0;i<v.size();i++){
            cout<<v[i].first<<" "<<v[i].second<<endl;
        }   
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值