ZOJ - 3609 Modular Inverse (扩展欧几里德求乘法逆元)

Modular Inverse

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist

8

分析:题目让求a相对于m的逆元 x

从题目可以知道 gcd(a,m)=1;

扩展欧几里德 a*x+m*y=gcd(a,m)

求出x

AC代码:

#include<stdio.h>
#include<string.h>
long long kzgcd(long long a,long long b,long long &x,long long &y)
{
	if(b==0)
	{
		x=1,y=0;
		return a;
	}
	long long ans=kzgcd(b,a%b,x,y);
	long long t=x;
	x=y;
	y=t-a/b*y;
	return ans;
}
long long solve(long long a,long long b)
{
	long long x,y;
	long long gcd=kzgcd(a,b,x,y);
	if(1%gcd)
	return -1;
	b/=gcd;
	if(b<0) b=-b;
	long long ans=x%b;
	if(ans<=0)
	ans+=b;
	return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		long long a,m;
		scanf("%lld%lld",&a,&m);
		long long ans=solve(a,m);
		if(ans==-1)
		printf("Not Exist\n");
		else
		printf("%lld\n",ans);
	} 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值