HOJ 1604 Cable Master

Cable Master

My Tags  (Edit)
  Source : ACM ICPC Northeastern European Regional 2001
  Time limit : 1 sec   Memory limit : 32 M

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.


Input

Input contains several test cases. The first line of each case contains two integer numb ers N and K, separated by a space. N (1 <= N <= 10000) is the number of cables in the stock, and K (1 <= K <= 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Process to end of file.


Output

For each case in the input, write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39
Sample Output
2.00


题目意思是有给定长度的n条绳子,要剪成K段一样长的,这K段最长是多长?

大致思想很简单,就是二分查找,上界是假设这n条绳子都连着,直接用绳子总长sum/k即可,下界为0

但是问题在于精度问题,我自己一开始用的是double,但是最后结果无论怎样都wa。所以没办法,我用整数进行运算。整数运算注意以下几点:

1、算绳子能切成几段时不需要四舍五入,直接去尾。

2、循环判断要用while(right-1 > left ),不-1的话会死循环。

3、最后循环结束要判断一下,right边界是否可行,因为最后right与left相差1时,mid等于left

代码如下:

#include <iostream>
#include <iomanip>


using namespace std;


int main()
{
    long long n,k,i,j,cnt,sum,left,right,mid,a,b;
    //double temp[10000];
    int len[10000];
    char c;


    while(cin>>n>>k)
    {
        sum=0;
        for(i=0; i<n; i++)
        {
            cin>>a>>c>>b;
            len[i] = (a*100+b);
            sum += len[i];
        }
        right = sum / k;
        left = 0;
        if(sum < k)
        {
            cout<<"0.00"<<endl;
            continue;
        }
        mid = (left+right)/2;
        while(right-1 > left )
        {
            cnt=0;
            for(i=0; i<n; i++)
            {
                cnt += len[i]/mid;
                if(cnt >= k)
                    break;
            }
            if(cnt>=k)
                left = mid;
            else
                right = mid;
            mid = (left+right)/2;
        }
        cnt=0;//right与left只差1时,判断right是否可行
        for(i=0; i<n; i++)
        {
            cnt += len[i]/right;
            if(cnt >= k)
                break;
        }
        if(cnt>=k)
            cout<<fixed<<setprecision(2)<<right*0.01<<endl;
        else
            cout<<fixed<<setprecision(2)<<mid*0.01<<endl;


    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值