POJ-1654 Area 解题报告

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2
题目链接:http://poj.org/problem?id=1654
题目大意:8,2,6,4,9,3,7,1分别代表北,南,东,西,东北,西北,东南,西南,按照给定顺序从原点移动点,最后确保点一定会回到原点,从而求构成封闭区域达的面积,输入n,表示有n组测试数据,每组数据有数字串,按照上面的对照顺序进行移动,从而获得区域图形,计算面积。
题目思路:可以将图形分为每两点和原点围成的三角形的面积和,利用叉乘,即向量积|axb|来计算三角形面积,a,b均为向量,每移动一次就重新更新点计算即可,注意只有移动三次及三次以上才会构成封闭区域,这里采用64位整型以防超限。
实现代码:
#include<cstring>
#include<iostream>
using namespace std;
__int64 Area(__int64 a,__int64 b,__int64 c,__int64 d)
{
	return a*d-b*c;
}
int main()
{
	int len,t;
	char a[1000003];
	int step[][2]={{-1,-1},{0,-1},{1,-1},{-1,0},{0,0},{1,0},{-1,1},{0,1},{1,1}};
	__int64 area,x1,y1,x2,y2;
	while(cin>>t)
	{
		for(int i=0;i<t;i++)
		{
			cin>>a;
			len=strlen(a);
			x1=x2=y1=y2=0;
			area=0;
			for(int j=0;j<len-1;j++)
			{
				x2+=step[a[j]-49][0];
				y2+=step[a[j]-49][1];
				area+=Area(x1,y1,x2,y2);
				x1=x2;
				y1=y2;
			}
			if(area<0)
				area=-area;
			__int64 res=area/2;
			if(res*2==area)
				printf("%I64d\n",res);
			else
				printf("%I64d.5\n",res);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值