Description
定义一个类SpecialPrime,只有一个静态成员函数
bool judge(int value)
用于判断value是否是一个回文素数。所谓回文素数是指一个数既是回文数又是素数。
Input
输入两个数m和n,0<m<n。
Output
区间[m,n]内的所有回文素数。
Sample Input
2 1000
Sample Output
2
3
5
7
11
101
131
151
181
191
313
353
373
383
727
757
787
797
919
929
#include <iostream>
#include<cmath>
using namespace std;
class SpecialPrime
{
public:
//注意是静态成员函数
static bool judge(int value)
{
int i;
int temp=value;
int sum=0;
int a;
while(temp >0)
{
a=temp%10;
sum=sum*10+a;
temp/=10;
}
if(sum==value )
{
int flag;
for(i=2,flag=1; i<=sqrt(value); i++)
{
if(value %i==0)
{
flag=0;
return false;
}
}
if(flag==1)
{
return true;
}
}
else
{
return false;
}
}
};
int main()
{
int m, n, i;
cin>>m>>n;
for (i = m; i < n; i++)
{
if (SpecialPrime::judge(i))
//可以通过类名或者对象访问类中的静态成员函数
cout<<i<<endl;
}
return 0;
}