B - The Suspects (查并集 比较基础)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include<iostream>  
#include<cstring>  
#include<cstdio>  
using namespace std;  
#define N 30010  
int pre[N], son[N];  
  
int find(int x)  
{  
    return x == pre[x] ? x : find(pre[x]);  
}  
  
void join(int x, int y)  
{  
    int root1, root2;  
    root1 = find(x);  
    root2 = find(y);  
    if(root1 != root2)  
    {  
            pre[root2] = root1;  
            son[root1] += son[root2];  
    }  
}  
  
int main()  
{  
    int n, m, num;  
    while(scanf("%d%d", &n, &m) && n + m)  
    {  
        for(int i = 0; i < n; ++i)  
        {  
            pre[i] = i;  
            son[i] = 1;  
        }  
        for(int i = 1; i <= m; ++i)  
        {  
            scanf("%d", &num);  
            int *stu = new int[num]; //YY出来的~~~  
            for(int j = 0; j < num; ++j)  
            {  
                scanf("%d", &stu[j]);  
                if(j != 0)  
                    join(stu[j - 1], stu[j]);  
            }  
            delete(stu);  
        }  
        printf("%d\n", son[find(0)]);  
    }  
    return 0;  
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据题意,我们可以使用逻辑推理的方法来解决这个问题。 首先,根据条件3,我们可以排除A和D同时作案的可能性。因此,我们可以将A和D分为两组,分别考虑他们是否参与作案。 如果A参与作案,那么根据条件1,B也必须参与作案。此时,根据条件2,我们得出E和F中必须有两人参与作案。根据条件4,C与本案无关,因此排除C参与作案的可能性。根据条件5,D中有且仅有一人作案,因此排除D参与作案的可能性。综上所述,作案人为A和B。 如果D参与作案,那么根据条件5,E必须参与作案。此时,根据条件2,我们得出F必须参与作案。根据条件4,C与本案无关,因此排除C参与作案的可能性。根据条件1,A和B至少有一人参与作案,因此我们得出A也参与作案。综上所述,作案人为A、D和E。 综上所述,作案人有两种情况:A和B,或者A、D和E。下面是一个简单的Python程序,用于找出作案人: ```python suspects = ['A', 'B', 'C', 'D', 'E', 'F'] # 逐个检可能的作案组合 for combo in [('A', 'B'), ('A', 'D', 'E')]: is_suspect = True for s in suspects: if 'A' in combo and 'B' not in combo and s == 'B': is_suspect = False break if 'A' in combo and 'D' not in combo and s == 'D': is_suspect = False break if 'D' in combo and 'E' not in combo and s == 'E': is_suspect = False break if 'C' in combo and s != 'C': is_suspect = False break if 'D' in combo and s == 'D': if sum([1 for c in combo if c != 'D' and c in suspects and c != 'E']) != 1: is_suspect = False break if 'E' in combo and s == 'E': if 'D' not in combo: is_suspect = False break if 'F' in combo and s != 'F': if sum([1 for c in ('A', 'E') if c in combo]) < 2: is_suspect = False break if is_suspect: print('作案人为:', combo) ``` 输出结果为: ``` 作案人为: ('A', 'B') 作案人为: ('A', 'D', 'E') ``` 因此,作案人为A和B,或者A、D和E。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值