UVA10815 Andy's First Dictionary

这篇博客介绍了XY学长通过阅读包含生词的英语文章来提高英语水平的过程。他以超高的智商快速记忆单词,并要求程序帮助整理不重复的单词列表,按字典序输出。
摘要由CSDN通过智能技术生成

Description

XY学长刚刚立下了再不过CET就直播xx的flag,为了不真的开启直播模式,XY学长决定好好学习英语。于是他每天都读一篇只包含生词的英语文章,并以自己高达450的智商在一秒钟之内记忆下来。

现在给你一篇XY学长今天要读的文章,请你写一个程序,输出他都学习到了哪些单词。
要求:如果文章中有相同的单词,那么仅仅输出一次;而且如果两个单词只有大小写不同,将他们视为相同的单词。

Input

测试数据将输入一篇文章。不超过5000行,每一行最多200个字符,并以EOF结束。

Output

按照字典序输出他学到的单词,每行输出一个单词,输出单词时所有的字母全部小写。 
数据保证最多有5000个需要输出的单词。

Sample Input

样例输入①

a a a a a a a a, a a a a a a.
a a a a b a a a. a? a!!!

样例输入②

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

样例输出①

a
b

样例输出②

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

Hint

输入可能包含标点符号,但标点符号显然不能算作单词的一部分。

源代码

#include<iostream>
#include<string>
#include<set>
#include<cctype>
#include<sstream>
using namespace std;
int main()
{
	int n,m;
	int i,j,k;
	set<string> word;
	set<string>::iterator it;
	string a,b;
	while(getline(cin,a))
	//getline把每行的字符输入到cin流里
	//再通过cin流赋值给string a
	//默认遇到回车结束一行,在(cin,a,delim)中,delim可以改为任意字符,即以该字符作为一行的结束标志 
	{
		for(i=0;i<a.length();i++)
		{
			if(isalpha(a[i]))//isalpha函数判断是否是字母,头文件cctype 
			a[i]=tolower(a[i]);//tolower函数用于把字母变为小写字母,相反函数为toupper() 
			else
			a[i]=' ';
		}
		istringstream istr(a);//istringstream对象可以绑定一行字符串,然后以空格为分隔符把该行分隔开来
		//把string a输入到string输入流(istringstream)里,保存在istr中 
		while(istr>>b)//利用istringstream类的特性,这里每次输入给b一个单词 
		word.insert(b);
	}
	for(it=word.begin();it!=word.end();it++)
	cout<<*it<<endl;
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值