4 Values whose Sum is 0

题目描述

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

输入

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

输出

For each input file, your program has to write the number quadruplets whose sum is zero.

样例输入

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

样例输出

5

# include <stdio.h>
# define N 4001
void insert(int Tree[],int X);
int Delmin(int Tree[]);
int A[N],B[N],C[N],D[N];
int sum[N*N],tree[N*N];
int main(){
    int n,i,j,k,m;
    long long res;
    while(~scanf("%d",&n)){
           for (i=0;i<n;i++)
                  scanf("%d %d %d %d",&A[i],&B[i],&C[i],&D[i]);
             for (i=0;i<n;i++)
                for (j=0;j<n;j++)
                    insert(tree,C[i]+D[j]);
                    k=0;
            while(tree[0])sum[k++]=Delmin(tree);
          for (res=0,i=0;i<n;i++)
                for (j=0;j<n;j++)
                  {
                      m=-(A[i]+B[j]);
                      res+=search(sum,k,m);
                  }
         printf("%lld\n",res);
    }
    return 0;
}
int search(int A[],int n,int key)
{
    int L=0,R=n-1,mid,num=0;
    while(L<=R)
    {
        mid=(L+R)>>1;
        if(A[mid]==key) {
            L=mid;
            while(L>=0&&A[L--]==key)num++;
            while(mid<n&&A[mid++]==key)num++;
            return num-1;
        }
        else if(A[mid]>key)
        R=mid-1;
        else L=mid+1;
    }
    return 0;
}
void insert(int Tree[],int X)
{
    int par,i=++Tree[0];          
    while(i>1)                    
    {
        par=(i>>1);                
        if(Tree[par]<=X) break;    
        Tree[i]=Tree[par];         
        i=par;
    }
    Tree[i]=X;                    
}
int Delmin(int Tree[])
{
    int i=1,L=2,root=Tree[1],X=Tree[Tree[0]--];
    while(L<=Tree[0])
    {
        L+=L<Tree[0]&&Tree[L+1]<Tree[L];
        if(Tree[L]>=X) break;
        Tree[i]=Tree[L];
        i=L;    L<<=1;
    }
    Tree[i]=X;
    return  root;
}

  • 10
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值