uva_10025 - The ? 1 ? 2 ? ... ? n = k problem


The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701



   比较简单的题目, 首先先找出满足1+...+n的和Sn大于或等于k的最小的n,用二分法找出,特殊情况k=0直接输出。第二个就是判断Sn的奇偶性是否与k相等,因为1~n中某一个数字m符号改为-号是,相当于n项和减小偶数2*m,所以Sn必定与k奇偶性相同。

#include <iostream>

using namespace std;

int main()
{
    int t, k;

    cin >> t;
    while ( t--){
        cin >> k;
        if ( k<0) k = -1*k;
        if ( !k){
            cout << 3 << endl;
            if( t) cout << endl;
            continue;
        }

        int a = 0, b = 50000,n;
        int Sn;
        while ( a <= b){                       //二分查找n的值
            n = ( a + b )/2;
            Sn = (n*n+n)/2;
            if(  Sn-n < k &&  Sn >= k) break; //Sn>=k
            else if ( k <= Sn - n ) b = n;
            else if ( k > Sn ) a = n + 1;
        }

        if( (Sn&1) != (k&1)){   //判断奇偶性是否相同,若不同Sn还需要加一个奇数
            if( n&1) n+=2;      // n为奇数,则n+1为偶数,需要n+2
            else n++;           // n为偶数,则n+1为奇数
        }

        cout << n << endl;
        if( t) cout << endl;
    }
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值