hdu 1394 逆序数

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11995    Accepted Submission(s): 7332


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L
 


 比较简单的题目,先用归并的方法求出初始序列的逆序数cnt,每次将第一个数放到最后,cnt减去小于这个数的数量,再加上大于这个数的数量,答案就是cnt出现过的最小值



#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

#define maxn 5005

int a[maxn];
int a1[maxn];
int b[maxn];

int get_inver(int *a, int l, int r)
{
    if(l==r) return 0;

    int ret = 0;
    int m = l+(r-l)/2;

    ret += get_inver(a, l, m);
    ret += get_inver(a, m+1, r);

    int i=l, j=m+1;
    int cur = l;
    while(cur<=r){
        if(i<=m && (a[i]<=a[j]||j>r)){
            b[cur++] = a[i++];
            ret+=cur-i;
        }
        else if(j<=r && (a[j]<a[i] || i>m)){
            b[cur++] = a[j++];
            if(cur>j) ret+=cur-j;
        }
    }

    for(int i = l ; i <= r; i++)
        a[i] = b[i];

    return ret;
}

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF){
        for(int i = 0; i < n; i++)
            scanf("%d", a+i);
        memcpy(a1, a, sizeof(a));

        int cnt = get_inver(a, 0, n-1);

        int ans = cnt;
        for(int i = 0; i < n; i++){
            cnt-=a1[i];
            cnt+=(n-1-a1[i]);
            ans=min(ans,cnt);
        }

        printf("%d\n", ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值