poj 2104 -- kth number 平方分割法例题

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 39585 Accepted: 12912
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion


挑战程序设计竞赛上平方分割法的例题。


找出指定区间[i,j]第k小的数。

区间内第k小的数x,即<=x的有>=k个,找到最小的且满足这个条件的x即是答案。二分枚举x得到答案。

用平方分割的做法(线段树当然也可以),将整个区间分成大小为b的一个个桶。每次查找<=x的个数的复杂度为:

1.对于完全包含在区间内的桶,直接二分O(logb),所以事先每个桶要先排序。

2.对于部分包含在区间内的桶,则直接线性查找O(b)

满足1的最多有n/b个桶,满足2的最多只有两个桶,所以每次查找<=x个数的复杂度为O((n/b)*logb+b),要使复杂度取最小,b大约取sqrt(nlogn),复杂度为O(sqrt(nlogn))。再加上二分枚举答案,就是O(sqrt(nlogn)*logn)

同时事先排序预处理复杂度为 O(nlogn)

总体复杂度为O(nlogn+m*sqrt(nlogn)*logn)


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;

#define maxn 100005

int n, m;
int a[maxn], a1[maxn], a2[maxn];

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF){
        for(int i = 1; i <= n; i++)
            scanf("%d", a+i);

        int b = sqrt(n*log(n+0.0)+0.0);
        if(!b) b++;

        memcpy(a1, a, sizeof(a));
        memcpy(a2, a, sizeof(a));

        for(int i = 1; i+b <= n+1; i+=b) sort(a2+i, a2+i+b);
        sort(a1+1, a1+n+1);

        int l, r ,k;
        for(int t = 0; t < m; t++){
            scanf("%d%d%d", &l, &r, &k);
            int s = 1+(l+b-2)/b*b, e = r/b*b;

            int ans;
            int lb=1, ub=n+1, mb;
            while(lb < ub){
                mb = lb+(ub-lb)/2;
                mb = a1[mb];

                int cnt = 0;
                for(int i = l; i < s && i <= r; i++) if(a[i] <= mb) cnt++;
                for(int i = e+1; i >= l && i <= r; i++) if(a[i] <= mb) cnt++;

                for(int i = s; i <= e; i+=b)
                    cnt += (upper_bound(a2+i, a2+i+b, mb)-a2)-i;

                if(cnt >= k ){
                    ans = mb;
                    ub = lb+(ub-lb)/2;
                }
                else
                    lb = lb+(ub-lb)/2+1;
            }

            printf("%d\n", ans);
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值