Time Limit: 8000MS | Memory Limit: 65536K | |
Total Submissions: 6169 | Accepted: 1651 | |
Case Time Limit: 2000MS | Special Judge |
Description
Demy has n jewels. Each of her jewels has some value vi and weight wi.
Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as
.
Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.
Input
The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).
The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).
Output
Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.
Sample Input
3 2 1 1 1 2 1 3
Sample Output
1 2
Source
Northeastern Europe 2005, Northern Subregion
这道题就是用贪心+二分求最大化平均值。
选前k个的时候用nth_element比用sort快多了...
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
#define maxn 100005
int ans[maxn];
int n, k;
double x;
struct node
{
int v, w;
int id;
bool operator < (const node &a) const
{
return v-x*w > a.v-x*a.w;
}
};
node a[maxn];
int main()
{
while(scanf("%d%d", &n, &k)!=EOF){
for(int i = 0; i < n; i++){
scanf("%d%d", &a[i].v, &a[i].w);
a[i].id = i+1;
}
double l = 0, r = 1e7+10;
while(l+1e-6<r){
double m = (r+l)/2;
x = m;
nth_element(a, a+k-1, a+n);
double tmp= 0;
for(int i = 0; i < k; i++)
tmp += a[i].v-x*a[i].w;
if(tmp+1e-5 >= 0){
for(int i = 0; i < k; i++)
ans[i] = a[i].id;
l = m;
}
else
r = m;
}
for(int i = 0; i < k-1; i++)
printf("%d ", ans[i]);
printf("%d\n", ans[k-1]);
}
return 0;
}