Trailing Zeroes (III) LightOJ - 1138

题目链接:https://cn.vjudge.net/problem/LightOJ-1138

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题意:给你一个n问你多少的阶乘末尾0位n个。

思路:n的阶乘后有多少个0判断n的阶乘种有多少个5相乘即可,然后用二分查找这个数。

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int zhao(int x)
{
    ll res=0;
    while(x)
    {
        res+=x/5;
        x=x/5;
    }
    return res;
}
int main()
{
    ll t;
    scanf("%lld",&t);
    for(ll kcase=1;kcase<=t;kcase++)
    {
        ll n,res=-1;
        scanf("%lld",&n);
        ll l=1,r=500000000;
        while(l<=r)
        {
            ll mid=(l+r)/2;
            if(zhao(mid)==n)
            {
                res=mid;
                r=mid-1;
            }
            else if(zhao(mid)>n)
            {
                r=mid-1;
            }
            else
            {
                l=mid+1;
            }
        }
        if(res!=-1)
        cout<<"Case "<<kcase<<": "<<res<<endl;
        else
        cout<<"Case "<<kcase<<": "<<"impossible"<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值