Ultra-QuickSort POJ - 2299 归并排序

问题:

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is
 sorted in ascending order. For the input sequence 9 1 0 5 4 ,

Ultra-QuickSort produces the output 0 1 4 5 9  .

                                                                          

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence
 element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0
题意:给你n个数,让你排序从小到大,只有相邻的两个数才能调换,问你最少需要调换多少次?

归并排序:例给出8个数:5,4,7,9,3,8,2,1;

(1)流程:

(2)合并两个有序数组的流程

归并排序模板;

#include <iostream>
using namespace std;
void merge(int arr[],int l,int mid,int r)
{
    int aux[r-l+1];//开辟一个新的数组,将原数组映射进去
    for(int m=l; m<=r; m++)
    {
        aux[m-l]=arr[m];
    }
    int i=l,j=mid+1;//i和j分别指向两个子数组开头部分

    for(int k=l; k<=r; k++)
    {
        if(i>mid)
        {
            arr[k]=aux[j-l];
            j++;
        }
        else if(j>r)
        {
            arr[k]=aux[i-l];
            i++;
        }
        else if(aux[i-l]<aux[j-l])
        {
            arr[k]=aux[i-l];
            i++;
        }
        else
        {
            arr[k]=aux[j-l];
            j++;
        }
    }
}
//递归的使用归并排序,对arr[l....r]排序
void merge_sort(int arr[],int l,int r)
{
    if(l >=r)
        return ;
    int mid=(l+r)/2;
    merge_sort(arr,l,mid);
    merge_sort(arr,mid+1,r);
    merge(arr,l,mid,r);
}

void my_merge_sort(int arr[],int n)
{
    merge_sort(arr,0,n-1);
}

int main()
{
    int a[6];
    for(int i=0; i<6; i++)
        cin>>a[i];
    my_merge_sort(a,6);
    for(int i=0; i<6; i++)
        cout<<a[i]<<" ";
    return 0;
}

本题答案代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 510000
using namespace std;
int a[N],aux[N];
long long ans;
void paixu(int l,int r,int mid)
{
    for(int i=l; i<=r; i++)
        aux[i-l]=a[i];
    int L1=l,L2=mid+1;
    for(int i=l; i<=r; i++)
    {
        if(L1>mid)
        {
            a[i]=aux[L2-l];
            L2++;
        }
        else if(L2>r)
        {
            a[i]=aux[L1-l];
            L1++;
        }
        else if(aux[L1-l]>aux[L2-l])
        {
            ans+=(mid-L1+1);
            a[i]=aux[L2-l];
            L2++;
        }
        else
        {
            a[i]=aux[L1-l];
            L1++;
        }
    }
}
void build(int l,int r)
{
    if(l>=r)
        return ;
    int mid=(l+r)>>1;
    build(l,mid);
    build(mid+1,r);
    paixu(l,r,mid);
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        ans=0;
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        build(0,n-1);
        printf("%lld\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值