Corn Fields POJ - 3254 状态压缩

问题:

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows: 

1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:有一块n行m列的矩形土地, 有的土地上有草,有的土地没有草,可以在这些有草的土地上放牛(用1表示),没有草的土地不能放牛(用0表示),而且相邻的土地不可以同时有牛,问农夫一共有多少种放牛的方案(一头牛都不放也是一种方案)。

思路:根据题目数据12*12的,所以很容易想到状态压缩。 先统计每一行有多少种放法,然后根据上一行的状态去判断当前这一行的状态。看代码更易理解。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<math.h>
#include<map>
#include<stdlib.h>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define PI acos(-1.0)
#define eps 1e-8
#define mem(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
#define mod 100000000
#define N 13
int n,m,a[N],b,num;//a数组表示每一行可以放牛的最多数量。
int dp[N][1<<N],sum;
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++)
        for(int j=1; j<=m; j++)
        {
            scanf("%d",&b);
            a[i]=(a[i]<<1)+b;//例如第i行为1 1 1 0 1,那么a[i]的最终值为29,29的二进制就为11101
        }
    num=(1<<m)-1;//num表示一行的最终多少种状态
    dp[0][0]=1,sum=0;
    for(int i=1; i<=n; i++)
        for(int j=0; j<=num; j++)
            if(((j<<1)&j)==0 && ((j>>1)&j)==0 && ((a[i]&j)==j))
                //判断左右是否相邻,a[i]&j==j这点需要好好想,a[i]二进制1的位置必须包含于j二进制1的位置
                for(int k=0; k<=num; k++)
                    if((k&j)==0)//k表示上一行的状态,因为上下相邻也是不行的
                        dp[i][j]+=dp[i-1][k];
    for(int i=0; i<=num; i++)
        sum=(sum+dp[n][i])%mod;
    printf("%d\n",sum);
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值