(POJ - 3254)Corn Fields

(POJ - 3254)Corn Fields

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16649 Accepted: 8791

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题目大意:给出m*n的矩阵,1代表可以放牛,0代表不可以放牛。上下左右相邻的两块地不能同时放牛,问一共有几种放牛的方式(注:一头牛都不放也算一种方式)。

思路:明显的状态压缩题。用f[i][j]表示第i行j状态,由于是第一次做状态dp,所以细节注释都写在代码里了,关键是判断不能放牛的情况和上下相邻的情况。

#include<cstdio>
#include<cstring>
using namespace std;

typedef long long LL;
const int mod=100000000;
const int maxn=1<<13;
int a[13][13];
LL f[13][maxn];

bool judge(int x)//判断该状态是否有两个1在一起,如果有则不满足条件 
{
    if(x&(x<<1)) return false;
    else return true;
}

bool check(int i,int x)//判断第i行x状态是否满足环境要求
{
    int j=1;
    while(x)
    {
        if((x&1)&&a[i][j]==0) return false;//x&1表示这一列放牛了,而a[i][j]=0表示这块土地不能放牛,矛盾
        j++;
        x>>=1; 
    }
    return true;
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        memset(f,0,sizeof(f));
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++) scanf("%d",&a[i][j]);
        for(int i=0;i<(1<<n);i++) //判断第一行i状态是否满足条件 
            if(judge(i)&&check(1,i)) f[1][i]=1;
        for(int i=2;i<=m;i++)//枚举行
            for(int j=0;j<(1<<n);j++)//枚举当前行状态 
                for(int k=0;k<(1<<n);k++)//枚举上一行状态 
                    if(judge(j)&&judge(k)&&!(j&k)&&check(i,j)&&check(i-1,k))
                        f[i][j]=(f[i][j]+f[i-1][k])%mod; 
        LL ans=0;
        for(int i=0;i<(1<<n);i++) ans=(ans+f[m][i])%mod;
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值