Max Sum Plus Plus HDU - 1024 (m段最大和)

问题:

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

题意:给定n个数,和m个段。求在这n个数中求出m个子段,使得这些子段的和最大。

思路:当前这个状态是dp[i][j],i 表示当前的段,j表示前j个数组成了当前的这i个段,并且保证dp[i][j]是当前的最优解。状态dp[i][j]可以从dp[i][j-1]转移过来,表示第j个数字正好可以和 i 个段的前j-1个数字相加的和是当前所在状态中最大的。状态dp[i][j]可以从dp[i-1][j-1]转移过来,表示第 j 个数字正好可以成为第 i 个段,并且使得和i-1个段相加的和是当前所有状态中最大的。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1000100],dp[2][1000100];
int sum[1000100],num[1000100];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        sum[0]=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];//求前缀和;
        }
        memset(dp,0,sizeof(dp));//数组清零;
        int x=1;//滚动数组;
        for(int i=1; i<=n; i++)//从第一段开始遍历;
        {
            for(int j=i; j<=m; j++)//遍历每一个数;
            {
                if(i==j)
                    dp[x][j]=num[j]=sum[j];//直接将前j个数的和赋给当前状态;
                else
                {
                    num[j]=max(num[j-1],dp[1-x][j-1])+sum[j]-sum[j-1];//更新最大值;
                    dp[x][j]=max(num[j],dp[x][j-1]);//把最大值赋给当前状态;
                }
            }
            x=1-x;
        }
        printf("%d\n",dp[n%2][m]);

    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值