hdu 1024 最大M子段和

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23234    Accepted Submission(s): 7922


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 
Output
Output the maximal summation described above in one line.
 
Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 
Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 
Author
JGShining(极光炫影)


推荐两篇blog:http://blog.sina.com.cn/s/blog_677a3eb30100jxqa.html
                            http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127085.html
#include <iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int m,n;
    int i,j;
    int max_dp;
    while(cin>>m>>n)//求n个数的数列的最大m子段和
    {
        int *a=new int[n+1];
        int *dp=new int[n+1];//dp[j]表示包括a[j]在内的最大i子段和
        int *pre_max_dp=new int[n+1];//pre_max_dp[j]表示a[1]~a[j]的最大i-1子段和

        //初始化
        for(int count=1;count<=n;count++)
        {
            dp[count]=0;
            pre_max_dp[count]=0;
            cin>>a[count];
        }
        dp[0]=pre_max_dp[0]=0;

        for(i=1;i<=m;i++)
        {
            max_dp=INT_MIN;//max_dp表示a[1]~a[j]的最大i子段和,初始化为不可能值
            for(j=i;j<=n;j++)//j有i个子段,j>=i
            {
                dp[j]=max(dp[j-1]+a[j],pre_max_dp[j-1]+a[j]);
                pre_max_dp[j-1]=max_dp;//更新数据,在i++后使用
                max_dp=max(max_dp,dp[j]);
            }
        }
        cout<<max_dp<<endl;//结束后的max_dp即为a[1]~a[n]的最大m子段和
        delete[] a;
        delete[] dp;
        delete[] pre_max_dp;
    }//end of while
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值