In Action HDU - 3339 最短路+01背包

问题:

                                            
Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe. 
Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it. 
But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station, we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use. 
Now our commander wants to know the minimal oil cost in this action.

Input

The first line of the input contains a single integer T, specifying the number of testcase in the file. 
For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction). 
Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between. 
Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.

Output

The minimal oil cost in this action. 
If not exist print "impossible"(without quotes).

Sample Input

2
2 3
0 2 9
2 1 3
1 0 2
1
3
2 1
2 1 3
1
3

Sample Output

5
impossible

题意:有n个基地,分别标号1..n,每个基地都有一定的能量,选择一些基地使得能量和大于总和的一半的情况下是消耗的油量最少,这些选择的点必须是与0连通的。起点的编号为0的基地。

思路:最短路+01背包,先找到编号为0到各个基地的最少耗油量,再把每个基地的能量加起来,用01背包找到满足条件且耗油量最少的最优解。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[120][120],dp[1010000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,a[120],sum=0,num=0;
        scanf("%d%d",&n,&m);
        memset(s,0x3f3f3f3f,sizeof(s));
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            s[i][i]=0;
        for(int i=1; i<=m; i++)
        {
            int t1,t2,t3;
            scanf("%d%d%d",&t1,&t2,&t3);
            if(s[t1][t2]>t3||s[t2][t1]>t3)
                s[t1][t2]=s[t2][t1]=t3;
        }
        for(int k=0; k<=n; k++)
            for(int i=0; i<=n; i++)
                for(int j=0; j<=n; j++)
                    if(s[i][j]>s[i][k]+s[k][j])
                        s[i][j]=s[i][k]+s[k][j];
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
            if(s[0][i]!=0x3f3f3f3f)
                num+=s[0][i];
        }
        for(int i=1; i<=n; i++)
            for(int j=num; j>=s[0][i]; j--)
            {
                dp[j]=max(dp[j],dp[j-s[0][i]]+a[i]);
                //printf("%d-%d ",j,dp[j]);
            }
        int flag=0;
        for(int i=1; i<=num; i++)
        {
            if(dp[i]>sum/2.0)
            {
                flag=1;
                printf("%d\n",i);
                break;
            }
        }
        if(flag==0)
            printf("impossible\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值