The order of a Tree HDU - 3999 二叉树

问题:

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely: 
1.  insert a key k to a empty tree, then the tree become a tree with 
only one node; 
2.  insert a key k to a nonempty tree, if k is less than the root ,insert 
it to the left sub-tree;else insert k to the right sub-tree. 
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape. 

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n. 

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic. 

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

题意:给你一个二叉搜索树,就是比父亲节点小的插入到父亲节点的左边,否则插入到右边,然后让你按照字典序最小的原则改变这个树的插入顺序,使树的形状保持不变。

思路:先建树,模板题,然后直接把前序输出出来即可,代码下;

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
    int v=0;
    node *l=NULL,*r=NULL;
};
int a[120000],t;
node* build(int x,node *cur)//建树模板题;
{
    if(cur==NULL)
    {
        node *root=new node;
        root->v=x;
        root->l=root->r=NULL;
        return root;
    }
    else
    {
        if(x>cur->v)
            cur->r=build(x,cur->r);
        if(x<cur->v)
            cur->l=build(x,cur->l);
        return cur;
    }
}
void print(node *root)//根左右
{
    if(root!=NULL)
    {
        a[t++]=root->v;//根
        print(root->l);//左子树
        print(root->r); //右子树
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        node *k=NULL;
        for(int i=1; i<=n; i++)
        {
            int z;
            scanf("%d",&z);
            k=build(z,k);
        }
        t=0;
        print(k);
        for(int i=0; i<t-1; i++)
            printf("%d ",a[i]);
        printf("%d\n",a[t-1]);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值