西北农林科技大学2024学年C++面向对象程序设计OJ——T3 用函数模板实现数据交换

一.题目描述

用函数模板实现数据交换(考察引用和函数模板)

Description

设计函数模板Swap,能够实现整型数与整型数、浮点型数与浮点型数、字符串与字符串的交换。

Input

int main()
{
    int a, b;
    double x, y;
    string str1, str2;
    cin >> a >> b;
    cin >> x >> y;
    cin >> str1 >> str2;
    Swap(a, b);
    Swap(x, y);
    Swap(str1, str2);
    cout << a << " " << b << endl;
    cout << x << " " << y << endl;
    cout << str1 << " " << str2 << endl;
    return 0;
}

Output

分别输出交换后的整型数、浮点型数和字符串。

二.输入与输出

Sample Input 1 

100 200
21.5 31.4
asdfqw iyjl

Sample Output 1

200 100
31.4 21.5
iyjl asdfqw


三.代码

#include<bits/stdc++.h>
using namespace std;
template<class T>
void Swap(T&x,T&y){
	T tmp = x;
    x = y;
    y = tmp;
}
int main()

{

int a, b;

double x, y;

string str1, str2;

cin >> a >> b;

cin >> x >> y;

cin >> str1 >> str2;

Swap(a, b);

Swap(x, y);

Swap(str1, str2);

cout << a << " " << b << endl;

cout << x << " " << y << endl;

cout << str1 << " " << str2 << endl;

return 0;

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

失忆已成习惯.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值